Kinetic Application Maintenance - Disable Kinetic UI

When I toggled to Off ‘Enable New UI’ on the Main Menu and Company notes, there are still menu items such as Part Class that are opening with Kinetic instead of Classic. Is this correct but seems buggy that you can’t disable all Kinetic forms or if this is the intended direction moving forward with some menu items opening only in Kinetic form. I believe Kinetic Application Maintenance overrides all settings unless I am missing something.

Make sure you disable it for All Companies, each individual company in the List. Basically your entire Kinetic Maintenance should have red x’s.

image

The Menu (All Companies) seems to be buggy and doesn’t do the job right.

I did disable all companies including individual companies in the list but it still did not disable all Kinetic forms.

Go to Settings > Preferences and set “Default Form to Use” to be Classic.
You’ll have to do it for each user. I made a UBAQ to do it for all easily.

UpdateUserFormStyle.baq (38.4 KB)

1 Like

I believe if you disable it Kinetic Application Maintenance, it grays out the option in the Settings since the Kinetic Application Maintenance overrides it. I am not sure if this is the intended process in the latest version.

We are trying to embrace Kinetic as much as possible and we struggle with exactly what you are finding but the opposite way (Classic forms opening instead of Kinetic).

I’ve found that the most consistent way to do this is:

  1. As others have said, turn Kinetic off in Kinetic Application Maintenance
  2. Set your (user) form style preference to Classic
  3. Clear the client cache
  4. Close the application
  5. Clear everything under C:\ProgramData\Epicor (we are cloud so I don’t know if this applies to on-prem folks)
  6. Re-open Epicor and cross your fingers.

In your step #2, it is grayed out and not selectable if you turn Kinetic off in your step #1. Which version are you testing with?

I wrote the UBAQ to not use the business object. It’s not going to care if it’s grayed out. Did you try it?

Yeah, you are right. I just double checked that on my end (version 2021.2.5) and if you turn Kinetic off, you can’t select it as your form preference any longer. Everything afterwards applies, though; clear the cache and the ProgramData\Epicor folders.

I cleared client cache and the program data folder but it still did not disable all Kinetic forms.

Do you know if you have any of the menu items deployed as Kinetic apps? I believe that will override even the Kinetic app maintenance settings.

You could also try doing ALT + click on a menu item. It should open up a form chooser to set your default for that particular app.

How did you disable them? I recall “toggle all” doesnt work, and everytime I did it individually it worked flawless :slight_smile:

You have to toggle it per company per menu item, dont use the Toggle All button on the folder, seems to be broken. Just go into each Item / Company on the left and toggle away, one at a time. That seemed to have worked for me

Actually in 10.2.700 I think they took away the Toggle All Button – so might be ok… Which version are you on Chai?

Drill down to every item it should show Part Class Red:
image

Version 2021.2

Using ALT also grays out the Default Form Type to be non selectable.

Im not sure I just disabled it in 2021.2 Demo – not an issue on my end.

Yes, seems buggy in the latest version.

Is that how your Part Class looks like? can you show me your screenshot.

I am on 2021.2.6

It displays Kinetic form only. Did you disable both the Main Menu and Individual companies?

Yes I disabled both. everything. one folder item at a time. Then I restarted my Client and I was set.

When I expanded the Main Menu node, it doesn’t display all the modules such as Part Class, etc to disable it item by item. I only did it at the Main Menu level to disable the child nodes. Everything is disabled off but still not working.