Leading Zero BAQ Export

Use wizard for text in Excel, choose data type for that column as text....

Or open a worksheet, format a column as text, copy/paste BAQ from grid Analyze tab (test) into Excel

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of Brian Kozic
Sent: Monday, July 02, 2012 7:13 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] Re: Leading Zero BAQ Export



I received a syntax error when using the "'" + string(part.PartNum).
Format X30 Datatype Character
Any thoughts?

Brian

From: vantage@yahoogroups.com<mailto:vantage%40yahoogroups.com> [mailto:vantage@yahoogroups.com<mailto:vantage%40yahoogroups.com>] On Behalf Of jckinneman
Sent: Monday, April 16, 2012 2:56 PM
To: vantage@yahoogroups.com<mailto:vantage%40yahoogroups.com>
Subject: [Vantage] Re: Leading Zero BAQ Export

You can try concatenating a single ' on the front of the value

"'" + string(part.PartNum) this usually has Excel treat the value as a string not a number.

Jim Kinneman
Encompass Solutions, Inc

--- In vantage@yahoogroups.com<mailto:vantage%40yahoogroups.com><mailto:vantage%40yahoogroups.com>, "michael.hutcheson@...<mailto:michael.hutcheson@...>" <michael.hutcheson@...<mailto:michael.hutcheson@...>> wrote:
>
> Hey folks,
>
> I have created a BAQ to export fields, part number being one of them.
>
> However, when I then open the exported csv file the leading zeros of any part numbers is being removed.
>
> Our part numbers are alpha numerica.
>
> I created a calculated field that simply had the below as the formula:
> STRING (Part.PartNum)
>
> I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.
>
> Any one know how to get round this?
>
> Regards,
>
> Michael
> Vantage 8.03.406 / Progress
>

[Non-text portions of this message have been removed]



[Non-text portions of this message have been removed]
Hey folks,

I have created a BAQ to export fields, part number being one of them.

However, when I then open the exported csv file the leading zeros of any part numbers is being removed.

Our part numbers are alpha numerica.

I created a calculated field that simply had the below as the formula:
STRING (Part.PartNum)

I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.

Any one know how to get round this?

Regards,

Michael
Vantage 8.03.406 / Progress
Hi,

I believe this is standard excel behavior? Because you're opening it in excel I think it is excel stripping the leading zeros.If you right click the csv file and choose 'Edit' the leading zeros should be there.



________________________________
From: "michael.hutcheson@..." <michael.hutcheson@...>
To: vantage@yahoogroups.com
Sent: Monday, April 16, 2012 3:23 PM
Subject: [Vantage] Leading Zero BAQ Export

Hey folks,

I have created a BAQ to export fields, part number being one of them.

However, when I then open the exported csv file the leading zeros of any part numbers is being removed.

Our part numbers are alpha numerica.Â

I created a calculated field that simply had the below as the formula:
STRING (Part.PartNum)

I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.

Any one know how to get round this?

Regards,

Michael
Vantage 8.03.406 / Progress



------------------------------------

Useful links for the Yahoo!Groups Vantage Board are: ( Note:Â You must have already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please goto: http://groups.yahoo.com/group/vantage/files/.%c2%a0
(2) To search through old msg's goto: http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto: http://groups.yahoo.com/group/vantage/linksYahoo! Groups Links



[Non-text portions of this message have been removed]
Just a quick check, did you open in notepad first to verify? Rather than letting excel open it for you?

Rob Bucek
Production Control Manager
PH: (715) 284-5376 ext 311
Mobile: (715)896-0590
FAX: (715)284-4084
[Description: cid:1.234354861@...]<http://www.dsmfg.com/>
(Click the logo to view our site)<http://www.dsmfg.com/>

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of michael.hutcheson@...
Sent: Monday, April 16, 2012 2:23 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Leading Zero BAQ Export



Hey folks,

I have created a BAQ to export fields, part number being one of them.

However, when I then open the exported csv file the leading zeros of any part numbers is being removed.

Our part numbers are alpha numerica.

I created a calculated field that simply had the below as the formula:
STRING (Part.PartNum)

I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.

Any one know how to get round this?

Regards,

Michael
Vantage 8.03.406 / Progress



[Non-text portions of this message have been removed]
Hi, yes, if you open in notepad first it is all ok, likewise if you rename the file to .txt then import into Excel via the Wizard the zeros are there. I was just wondering though if the csv can be opened without the extra steps.

Micahel

--- In vantage@yahoogroups.com, Rob Bucek <rbucek@...> wrote:
>
> Just a quick check, did you open in notepad first to verify? Rather than letting excel open it for you?
>
> Rob Bucek
> Production Control Manager
> PH: (715) 284-5376 ext 311
> Mobile: (715)896-0590
> FAX: (715)284-4084
> [Description: cid:1.234354861@...]<http://www.dsmfg.com/>
> (Click the logo to view our site)<http://www.dsmfg.com/>
>
> From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of michael.hutcheson@...
> Sent: Monday, April 16, 2012 2:23 PM
> To: vantage@yahoogroups.com
> Subject: [Vantage] Leading Zero BAQ Export
>
>
>
> Hey folks,
>
> I have created a BAQ to export fields, part number being one of them.
>
> However, when I then open the exported csv file the leading zeros of any part numbers is being removed.
>
> Our part numbers are alpha numerica.
>
> I created a calculated field that simply had the below as the formula:
> STRING (Part.PartNum)
>
> I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.
>
> Any one know how to get round this?
>
> Regards,
>
> Michael
> Vantage 8.03.406 / Progress
>
>
>
> [Non-text portions of this message have been removed]
>
This is an Excel "feature". Two possible ways to work around it:



Use the Import Text option instead of just opening the CSV file. In
that wizard, find the column with the part numbers, and change the
format to Text (instead of General). These import specs can be saved
to speed up the process the second time.



If you're cutting & pasting, change the format for the entire column A
to Text (from General), the paste in your part numbers.



Thanks,

Brian.



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of michael.hutcheson@...
Sent: Monday, April 16, 2012 3:23 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Leading Zero BAQ Export





Hey folks,

I have created a BAQ to export fields, part number being one of them.

However, when I then open the exported csv file the leading zeros of any
part numbers is being removed.

Our part numbers are alpha numerica.

I created a calculated field that simply had the below as the formula:
STRING (Part.PartNum)

I have entered X(20) for the format and Character as the data type, but
again, when I open in Excel the leading zeros are being removed.

Any one know how to get round this?

Regards,

Michael
Vantage 8.03.406 / Progress





[Non-text portions of this message have been removed]
Ok thanks Brian.

--- In vantage@yahoogroups.com, "Brian Roberts" <broberts@...> wrote:
>
> This is an Excel "feature". Two possible ways to work around it:
>
>
>
> Use the Import Text option instead of just opening the CSV file. In
> that wizard, find the column with the part numbers, and change the
> format to Text (instead of General). These import specs can be saved
> to speed up the process the second time.
>
>
>
> If you're cutting & pasting, change the format for the entire column A
> to Text (from General), the paste in your part numbers.
>
>
>
> Thanks,
>
> Brian.
>
>
>
> From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
> Of michael.hutcheson@...
> Sent: Monday, April 16, 2012 3:23 PM
> To: vantage@yahoogroups.com
> Subject: [Vantage] Leading Zero BAQ Export
>
>
>
>
>
> Hey folks,
>
> I have created a BAQ to export fields, part number being one of them.
>
> However, when I then open the exported csv file the leading zeros of any
> part numbers is being removed.
>
> Our part numbers are alpha numerica.
>
> I created a calculated field that simply had the below as the formula:
> STRING (Part.PartNum)
>
> I have entered X(20) for the format and Character as the data type, but
> again, when I open in Excel the leading zeros are being removed.
>
> Any one know how to get round this?
>
> Regards,
>
> Michael
> Vantage 8.03.406 / Progress
>
>
>
>
>
> [Non-text portions of this message have been removed]
>
You can try concatenating a single ' on the front of the value

"'" + string(part.PartNum) this usually has Excel treat the value as a string not a number.

Jim Kinneman
Encompass Solutions, Inc

--- In vantage@yahoogroups.com, "michael.hutcheson@..." <michael.hutcheson@...> wrote:
>
> Hey folks,
>
> I have created a BAQ to export fields, part number being one of them.
>
> However, when I then open the exported csv file the leading zeros of any part numbers is being removed.
>
> Our part numbers are alpha numerica.
>
> I created a calculated field that simply had the below as the formula:
> STRING (Part.PartNum)
>
> I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.
>
> Any one know how to get round this?
>
> Regards,
>
> Michael
> Vantage 8.03.406 / Progress
>
I received a syntax error when using the "'" + string(part.PartNum).
Format X30 Datatype Character
Any thoughts?

Brian

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of jckinneman
Sent: Monday, April 16, 2012 2:56 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Re: Leading Zero BAQ Export



You can try concatenating a single ' on the front of the value

"'" + string(part.PartNum) this usually has Excel treat the value as a string not a number.

Jim Kinneman
Encompass Solutions, Inc

--- In vantage@yahoogroups.com<mailto:vantage%40yahoogroups.com>, "michael.hutcheson@..." <michael.hutcheson@...> wrote:
>
> Hey folks,
>
> I have created a BAQ to export fields, part number being one of them.
>
> However, when I then open the exported csv file the leading zeros of any part numbers is being removed.
>
> Our part numbers are alpha numerica.
>
> I created a calculated field that simply had the below as the formula:
> STRING (Part.PartNum)
>
> I have entered X(20) for the format and Character as the data type, but again, when I open in Excel the leading zeros are being removed.
>
> Any one know how to get round this?
>
> Regards,
>
> Michael
> Vantage 8.03.406 / Progress
>



[Non-text portions of this message have been removed]