Method Directive working for updated but not new

Epicor version: 9.05.701

I wrote a BPM (method directive) using Memo.Update, this fires an email everytime a memo behind a job is updated. It works great. See 2 x screenshots below.

Problem: It doesn’t fire an email for newly created memos, only updated…So, i created a new BPM and used Memo.GetNew thinking this would be the trigger for a new memo created…however, it doesn’t fire…the screenshots are the third and fourth below…if anyone can help, i’d appreciate it!


Check both Added Records and Updated Records.

Hi, Yes, - all 4 shortcuts “jobnum”, “memodesc”, “userid” and “memotext” are all ticked ADDED and UPDATED.

tried changing this part too…but still no joy

If this is something you want to happen for all records, updated and added, I would suggest an Standard Data Directive on the Memo table instead of a Method Directive.

1 Like


I did look at that, but its not easy to send an email that way via Data Directive…there is no drop down for it…i know it could be written via ABL but i’m no expert at that.

apologies…i was looking at “in transaction”

works a treat. thank you so much for your help.