Microsoft Report Builder 2019

Some folks were concerned about using Microsoft Report Builder 2019 to customized Epicor Reports. Rest assured that 2016 and 2019 work fine. I am using Report Builder 2019. Just make sure that your team is using at least 2016+ or they won’t be able to open up a .rdl with 3.0 (2014).

Most of Epicor Reports have been built using Report Builder 3.0 (2014) which is not backwards compatible with Report Builder 2016 or Report Builder 2019. However Report Builder 2016 works with .rdl’s created with 2019.

If you open a .rdl that is created with 3.0 (2014) it’s xml will simply be converted (slightly) to the 2016 schema. You can’t download the old version from Microsoft anymore.

You will be fine, just make sure your team is using similar or newer Report Builder.

Versions:
Report Builder 3.0 (2014) [12.0.x]
Report Builder 2016 [15.0.900]
Report Builder (2019/2020) [15.0.19210] Same Schema as 2016

6 Likes

Thanks @hasokeric!

Hm, only 3.0 worked for me, last time I tried a newer version I got an error when I uploaded the report back to the cloud.

Hmmm. I remember we were SSRS 2014 and I used Report Builder 2016 fine on-prem.

I think it depends on the version of SSRS (SQL).

1 Like

Mr. Evan_Purdy is correct.

I have some SaaS MT customers that require 2014.

I believe Mr. Hasokeric is also correct - it depends on the SQL version.

I guess one lucky thing is that if the report is 2014 and you download it and then updated it using 2016 report builder. It will error out when you try to upload it back to the cloud.

Always make a backup just in case first.

DaveO

Or keep it in Source Control. There is a REST function to upload reports. There are also PowerShell scripts to manage SSRS.

Hey @hasokeric! My computer crashed recently and I’m having to use Report Builder 2019 since that is the only download MS is offering. I had been on 3.0. Are you saying that once I open and save a report in 2019, then someone else opening it in version 3.0 will be unsuccessful?

Also, are there any tricks to connecting to the report server in 2019? Neither I or my IT person have been able to get connected :frowning: I keep getting a HTTP status 401: unauthorized error.
-> edit: scratch that. ended up finding a download for 3.0 and connected now! :sweat_smile: guessing that has something to do with SQL Server 2012…?

Thanks for your help!

You can download any version of report builder. Download the version year that matches your SQL server (to be safe).

2 Likes

Where? :slight_smile: I had to go to a Piracy Torrent site

1 Like

2012 SP4:
https://www.microsoft.com/en-us/download/details.aspx?id=56043

Questions on this (sorry for my ignorance…)

  1. How do I tell what version of Report builder I am on? There is no longer a handy little About … under the Help menu and there is no version on the splash screen. I think I am more recent than 3.0 because I don’t have 3.0 on the splash screen and it used to be there.

  2. We are on 10.2.200.6 and as I recall our reports were built in Report Builder 3.0. How do I go about doing that? I downloaded a report, opened it and saved it. When I tried to upload it, I got the error below. I didn’t see any sort of option to Save the report as an earlier version…

Error:

The definition of this report is not valid or supported by this version of Reporting Services. The report definition may have been created with a later version of Reporting Services, or contain content that is not well-formed or not valid based on Reporting Services schemas. Details: The report definition has an invalid target namespace ‘http://schemas.microsoft.com/sqlserver/reporting/2016/01/reportdefinition’ which cannot be upgraded.

I could not find a way to download Report Builder 3.0…

How do we get around this?

—sam