New E10.2.200.5 Instalation, Epicor Help Is Blank


I’ve just installed a fresh installation of Epicor, with just the demo DB up and running. The Epicor Help extension has deployed/installed successfully, and all the files are in the IIS folder and the application pool is running, however when you access help it’s blank.

A browser window pops up, however all you have is the navigation bar at the top (back, refresh, home etc.) and the Annotations pop up at the bottom, no actual content is displayed.

This is a clean E10 installation, on a clean Windows Server 2016, so the only site in IIS is the default. I’ve a call open with Epicor, however I thought I’d post here in case others have seen this.


You have to go to either Company Maintenance or Company Configuration there is a Help URL field which you have to populate with the URL where you deployed the Help Contents to. Do you have that populated?

1 Like

Yep, Company Maintenance has the value configured, and in some clients I’ve added it into the .sysconfig as well.

Just curious if you login as any other user but manager, does it work? (assuming you are logging in as manager)

2nd - What happens if you try to navigate to the URL via your browser?

It’s the same for all users.

Also just browsing to the Extension URL does nothing, but I can access in a browser the files within e.g. ‘enu/Standard/tocnav.html’.

Can you go to your Admin Console and take a screenshot of your Help Extension Tab? Curious what settings and Poll you set in your deployment.

Btw here is one of mine:

Sure, here’s mine…

Interesting looks good - if you were to go to that URL you should get a HTTP Error 403.14 - Forbidden which means its working.

I wonder if something else is using your Port 80 - I would go to the IIS Settings and check your logs and bindings in IIS Settings.

That was Epicor’s first thought as well, however the bindings in IIS are just port 80 for the default site, nothing else is using it.

I’ll have to root around the logs as well to see if there’s anything obvious.

I would try going to Edit Settings -> Connect As… (in IIS) and instead of Pass-Through actually fill in your service account; see if that does the trick. I had to do that for 10.2 Report Agent, for some reason Pass-Through failed.

If you added a binding in addition to 80 to another port like 8081 see if that works.

I’ll give that a punt and let you know how I get on, thanks…

No joy I’m afraid :frowning:

@Fatboy40 I’m currently having the same issue in 10.2.300.3. If you find a solution id be interested.

As soon as Epicor come up with the solution I’ll let you know / update this thread. At the moment it’s going nowhere fast, we’re going round in circles :persevere:

I usually setup just one Help site and then use it for all environments. I have found doing it this way is much simpler. One thing I would look at is your AppPool Identity access rights. I would also make sure your App Pool Identity is set to ‘ApplicationPoolIdentity’.

Try this:

Open IIS manager on the Appserver
1.IIS Manager > Sites > Website
2. Double click ‘Authentication’
3. Select Anonymous Authentication
4. From the Actions Panel, select Edit
5. Select Application Pool Identity and click ok.


The problem in the end was Windows itself :rage:

Even though I’d been overly cautious when specifying the required Roles and Features for IIS, checking again and again, Windows somehow did not install some of them (no errors reported).

I’ve gone over it again incredibly carefully and Epicor Help is now fine.


I appreciate the update! Thanks for coming full circle :slight_smile:

What items did not install for you? I’m on the latest version and have tried everything I can think of from posts on here to previous knowledge and I can’t for the life of me get application help to load.

I followed the “Configure Server Roles (Windows Server 2016)” religiously, however after installation it had dropped a few random things like “Static Content” (I can’t remember the others).

@Fatboy40 Found my issue. Our server is on windows server 2012R2. And the highest framework and ASP are (4.5) and 10.2 requires 4.6. So I will update the OS to 2016 and should fix it.

1 Like