Epicor Help not working : Unable to load online help

Hello folks,

I have installed epicor help multiple times, even after tried by creating separate instance also my help link is incomplete as shown below.

When i check the same in folder i can find the html files. Kindly suggest how it can be fixed.

Note : I have verified the settings and features as mentioned in this link https://epiusers.help/t/unable-to-load-online-help-error/36058

I get lots of problems with help loading. While not a final solution, hitting the refresh icon in the help window sometimes does the trick.

Not sure if it’s related, but the first time(in a session) that I try to access the Help on the menubar in any E10 window, it takes several seconds after clicking help, before the menu opens up.


You need to make sure you have an active Epicor session. That does not mean just logging into the application like it used to. Most of the times I have to retrieve a record or I sometimes save something in an entry form to make sure my session is truly active.

We have a a 15 minute license timeout set on most of our user accounts and if your license is timed out I have noticed Help does not always load.

1 Like

Thanks Kristine,

As the default timeout settings is set to 5 minutes as shown in below. I have changed to 900, still facing the same issue.


I was referring to the User Account Maintenance setup in the application. It looks like you are updating the application pool settings.

Now I’ve attached the screen shot of my epicor education instance. I’m getting the same error.

Kindly suggest.-Much thanks.

If you haven’t yet restarted the app pool it would be good to do so just to be sure all changes are applied.

I have restarted the application pool as well restarted entire virtual machine. Is that something relevant to patch version? Currently i’m using, do we have any bug on this patch??

@Kathir I had the same problem below was my solution:

  1. Navigate to C:\ inetpub and delete all my help folders (websites) for my attempted trials
  2. Delete applications pools regarding help trials
  3. Remove help URL from config editor’s sys configs for my sites
  4. Navigated to admin console and for my application server’s extensions for help I chose to create a new help instance with a new application pool that uses a custom account with valid permissions.
  5. Redeployed the app server and then logged in and set company maintenance help url to the new instance I made.
  6. Cleared cache and restarted site from admin console and application help works now.
1 Like

I have deleted the entire virtual machine while tried to install Help i’m getting below error.

Is the Windows Search Service installed an running?

1 Like

What version of E10 are you running?

My Help installation (for 10.1.400) wasn’t done as an Extension.

8.1 Install Epicor Online Help for 10.1.400

Use these steps to install the Epicor ERP online help system available with this release. The Windows Search
Service feature must be installed in order to use the Epicor Help system. During the installation, if prompted to
install the Windows Search Service, use the Windows operating system Add Roles and Features wizard.

  1. On your server, go to the EpicorHelp folder on the server where your Epicor application is installed. For
    example, go to C:\Epicor\ERP10[product version]\SupplementalInstalls\Epicor Help.

Note If you want to install the Epicor online help on a separate server, go to that server and use
remote access to navigate to the shared EpicorERP10 folder on your Epicor server. From that remote
shared folder, run the Epicor Help Installer.

Note If you have installed an update to the base Epicor ERP 10 application, for example, Epicor ERP
10.1.400.x, you must use the updated installer. For example, go to C:\Epicor\ERP10[product
version]\Updates[update version]\SupplementalInstalls\EpicorHelp.

  1. Double-click the HelpInstaller.exe file to run it. The Epicor Help Installer dialog opens. Your dialog may
    look similar to the following: …

Never mind. I now see you’re on 10.2.200.

FWIW - seems like lots of issues with 10.2.xxx

December 2020

Is anyone’s help broken again? Mine in 10.2.600 is when viewed from Epicor.


“An error has occurred in the script on this page.” is an indication of being broken?

I see that pretty often.

FWIW - my help (using the epicor URL: https://help.epicor.com/102300) is working.