No Transaction Types setup in fresh install of E10

Fresh install of E10.1.400.19 and the Transaction Types don’t appear to be setup.

According to E10 Help…

The application installs with default GL transaction types, and you select and display each type on this sheet. For example, GL transaction types define the posting process for inventory, invoices, and bank reconciliation.

Yet when I launch GL Transaction Type and do a search, I find there are none defined.

I can’t imagine that I would have to go through and create every single one.

Any guidance would be greatly appreciated.

Calvin

Did you import the posting rules?

Get Outlook for iOShttps://aka.ms/o0ukef

Is this a task to be done in DMT? Or something extra after installing E10?

Not through DMT. Our consultants from TriGem imported them for us and I took some notes.

The posting rule files are in the install folder, I’m hazy on the details of the process. I can tell you they are not imported during setup and need to be done manually.

Get Outlook for iOShttps://aka.ms/o0ukef

Thanks. I’d have never figured that out. I scoured the DMT menus and the Epiror Implementation guide. But all signs pointed to them being setup automatically.

Searching the old Yahoo archives yielded the solution - to

on E10 if you want to import all of them you can just run “User Run Conversion” # 230

The conversion workbench is located in Upgrade/Mass regeneration folder in E10

https://groups.yahoo.com/neo/groups/vantage/conversations/topics/136403

You should also be able to import them using Import ACTType under the Actions menu in GL Transaction Type Maintenance. The posting rules zip file needs to be unzipped before importing.

Answerbook 819SYD also has some good information on Transaction Types and Posting Rules. Although its primary topic is about upgrading, it gives details on the import functionality.

I assume that “230” is the value in the “RunSequence” column of the “User Run Conversions”? I don’t see this number…

Also, the link appears to behind a login wall; it wants me to log into yahoo.

Can you post a link to Answerbook 819SYD?

I don’t see the “Import ACTTYpe” menu, I see “Import GL Transaction Type” instead:
04%20AM

In any case, where do you get the post rules from the import? I tried exporting from the E9 GL Transaction Type Maintenance window but it created a bunch of XML files, not a zip file. What flags should I select from tune “Install Default / Import GL Transaction Type” dialog?
50%20AM

If I just select “Import All” I get:

If I say “Ok” I get:


Which sounds scary enough that I dare not click “Ok” again…

Here’s a link to that Yahoo thread in this sites archives

Replying to myself,this appears to be Answerbook 819SYD. (May need to append your own user id to the end of that URL)

Thanks! Is there a conversion id or description I can look for since “# 230” does not show up on my system?

I think the menu changed since 10.1.

10.1.400
image

And

10.2.300
image

And the Conversion Workbench in 10.1.400

I can’t find the Conv Workbench in 10.2.300

I found something that looked like it might be it - #540 “Import GL Transaction Types”. But after running, I still get an error “active revision for transaction type ap invoice was not found” when I try to create receipt lines.

That does look like it. Same “cvpe0000”

BTW - I did find Conversion workbench in 10.2.300, I had to log in as a SecMgr

Since the conversion appeared to run but did not fix the issue, is it even worthwhile to try the import? In GL Transaction Type Maintenance, I see that there are almost 50 Transaction Type UIDs… but I was wondering if something isn’t set up right which a reimport would fix (for instance, maybe they aren’t active or something?)

I didn’t see any issues with the conversion, it finished - but I do notice that if I bring up the AP Invoice transaction type in GL Trans Type Maint There is a red “Conversion Errors” button which I’m not sure how to get rid of. How do I see/fix the errors?

It was almost 3 years ago that I ran into this. And it was during a fresh install of 10.1.400.

I remember struggling with it, but not what the exact issues were.

I’m in the process of upgrading to 10.2.300 (10.1.400 is our Production system). But since that’s an upgrade, I’m assuming whatever I did in 10.1.400, will carryover to 10.2.300

One note … I do have an “empty” company setup in 10.2.300, and when I search for GL Tran Types, I get nothing.

Using the “Import GL Tran Type” (in 10.2.300), I can see:

I assume I would mark the “Import All” checkbox

In Kinetic 2021.2.3. ConversionID: cvpe0000, is not SEQ 540, vs 230 stated above.