Print error - user

I have a user that is getting this error when they try to print. They can print preview fine and print that way. Anyone know how to fix this? I am guessing he clicked something. He has done a few odd things in the last few days.

I tested it on my PC and can print fine.

Is it possible the user has ‘Send To OneNote 2016’ listed twice in Devices and Printers on the workstation.

Even if they did. I would think this is the screen most users get to select a printer. this screen…

The correct printer is selected as a default.

I’m sorry, this isn’t very helpful but this made me Laugh-Out-Loud. :smile: When aren’t users doing odd things to make these kinds of things happen!

What is showing in the full drop-down list of Printers available on the Client? What happens if you select a different printer? Maybe you need to remove and re-map that printer on the Client?

1 Like

He never gets the screen SSRS CLent Printer…Just the error. That second screen shot it what he should get.

He clicked some check boxes for menu items and made his screen blank; then click and another on to make his favorites go away. SIGH

I logged on his computer and I get the same error message. I have changed his default printer and set it back. I have cleared client cache…no luck

1 Like

Ah-ha! I understand now. Sorry, I was confused as to where the screenshots were coming from exactly. Okay, I believe I’ve run into this sort of thing before, I think…but it was much easier to set the “Epicor Default Client Printer” in E9.

Okay, so what if you go to Start - … - Printers and Faxes on the Client machine and look to see which Printer is set as the default? While you are looking around in there do you see anything listed as a “One Note 2016” printer? If you can, and can easily get it back or don’t need it, I would remove it. Then try again…

it is only installed once.

I did check that. the correct printer is set to default “Accounting” and there is only one note 2016 installed.

1 Like

Or does he have some sort of a Personalization on the form perhaps?

I get the same error when I log on Epicor on his computer so not a personalization. Plus it is happening to anything he is printing.

Are you able to delete/disable that One Note 2016, try it, and then re-create it?

1 Like

I can try…I don’t think he uses it

Oh wait! I found something else to try…(if you haven’t tried that already)

Clutching at straws… But does the user have any print jobs queued in either the windows print manager, or the E10 Sys Task Monitor?

I’m sorry I don’t know of a better way to do this but if you open up a Dashboard and click File - Print. You will see a list of printers. The one highlighted in gray, for some reason, is I think what Epicor uses as it’s “Epicor default printer” and the one with the green check mark is the “PC’s default printer”. I’m assuming you will see the “Accounting” printer with the green check mark and the “One Note 2016” with the highlight. Click on the “Accounting” printer to highlight and then click “Apply”. Then try to print and see if that works.


We used to run into this issue in E9. But since we were always presented with this type of a Print box, once we figured out what was happening, we were able to fix the issue a lot easier than this…so you want both the green check mark and the gray highlight on the default printer that you want Epicor to use. :slight_smile:


I didn’t see anything in Task Monitor; I alwasy check that first. There is something stuck in the windows print que…hmmm.

I removed the One Note priter and now it works fine. I have no idea how to add that back…LOL

1 Like

Wait until someone complains about it being missing. :slight_smile:


I think it auto-magically adds itself back when the user reboots or logs out back in to Windows. Microsoft wouldn’t want anyone to get away from OneDrive/OneNote you know.


:joy: Yea, I’m sure no one will notice it and if they do say, “oh my, how in the world did that happen!? Darn Gremlins again!” :space_invader: :smiling_imp: :ghost: :alien: (My typical response.) LOL


We all got your back! :wink: LOL!

1 Like