Random screens not loading in Kinetic

We’ve been having random issues with some Kinetic screens not loading (getting errors).

It initially happened about a week ago where Part Entry wouldn’t load. I thought perhaps it was a customization issue… so I turned off a customization layer, saved… and the form then loaded. I turned the customization layer back on… and it worked as usual. It’s like it needed refreshed or something.

It happened again with Order Entry… I did the same “fix”… and it started working.

This morning it happened with PO Entry (and PO Tracker). But we don’t have any customization layers on these screens… so there’s nothing I can find to do to “refresh” these menus.

We just get the below error:

This is company wide… not just me. Classic PO Entry will load… but Kinetic will not. Error occurs in both Desktop Client and Web Browsers.

Not sure how to correct this issue… but this is the 3rd form to randomly have this issue over the past week or so.

Had this happen yesterday on the PO Print dialog, specifically for one user who was using the desktop client. I forced the dialog to open in Classic mode via Menu Maintenance, just to get around it. Not sure what the root cause was/is.

Thanks Andrew. I’ve entered an EpicCare ticket… I’ll let you know if/when I get a response.

I have seen this when the browsers are waiting for an update, and there was patching done yesterday. I had one person with a 401 this morning and a reboot after applying patches seemed to fix it.

Yes this has been happening to us too. I finally received instructions on my most recent case on copying and then clearing the cache on the server to try to get to the root of it (the next time it happens).

Can you share those instructions?

We’re on the cloud, so I don’t have access to clear the server cache anyway.

I have tried to clear the individual client cache, but that didn’t solve the issue.

We’ve been getting these errors for over a year & support has never been able to track down a cause. Order Entry, Job Entry, PO Entry…incredibly frustrating.

These are the instructions I got from support (our issue is with order entry specifically):

The path to the cache file will be on the deployment server and look something like this: deployment/server/apps/metaui/Erp.UI.JobEntry/cache (note: this is the Job Entry path, you’ll want the Order Entry path). There is no harm in deleting the cache as it will auto regen if it’s not there or if the existing has expired.

So the Action Items that would be helpful are as follows if we have another event:

  1. Create a ZIP back up of metaui/…/cache folder (include metaui on down to cache, name it “bad”)
  2. Delete the cache file
  3. Open Order Entry
    IF the form loads with all of the content correctly, THEN
  4. Create a ZIP back up of the metaui/…/cache (include metaui on down to cache, name it “good”)

We have been experiencing the same issue with our Order Entry and Tracker on the web app since Wednesday. Desktop client works fine. Support hasn’t been able to give any suggestions that work.

They told us to delete personalizations on the specific app screens, so I went to client version and reset to default in personalization but it still won’t load on the web.

Anyone had any luck?

Republish your custom layers, that is what has fixed it for us several times. If you see my post above yours, support seems to suspect it has to do with the caching of the layers on the server itself. Perhaps republishing them recreates that cache.