Task Agent Errors

Yesterday, we had a problem with our app server and, in the end, I had to rebuild the site to get it to work.
All seemed good until this morning. The task agent seems to be in a constant error state.

Report generation actually works just fine, but when a BPM sends an email, it throws the below message into the ICE Task Agent event viewer.

The BPM is behaving just fine and I can see the proper messages showing up in the Ice.MailQueueBody table, but they aren’t getting sent out from there. Instead, it’s giving me that error.

I have tried stopping/starting the agent, restarting the agent service, reinstalling the task agent, and creating a new agent. I have also purged everything from the MailQueue table in hopes that it was hung up on one, but they keep getting queued up there.

Anyone have any idea how to sort this out?

I ended up deleting the app server and creating it from scratch.
That seemed to do the trick.

Hi Aaron

I realize this was a very old post ha ha almost 2 years now, but we are suddenly having this same issues with emails not sending…all just stopping at the server and sitting in Ice.MailQueue table…

Deleting the app server…not something I have done…how does that effect the rest of the system?

Before you go to deleting and recreating the app server, start with stopping/starting all of the task agents then if that doesn’t solve it then delete and uninstall the task agents and remake them.

Failing all of that then recreating the app server is the next possible solution and would have some downtime.


I did start and stop all of the task agents and that didn’t help (its worth noting that both my Pilot and Test instances are working fine on the email front, NONE are going into Queue).

The ticket I have currently going with Epicor is sitting at the “updated Task Agent” stage, which I guess is essentially what you are saying with regards to deleting the current task agent…if I delete the current agent that would create downtime as well no?

In between stop/start of task agents and recreating the App Server, restart the Task Agent Service.

This is different that the Agents themselves


If that gives you trouble, you may need to do it through the Services Control panel

While you’re there in Services. Check the Logon credential of that service.


The UI would not be down, just the background processing. I am running 10.2.400.15 and I had updated the task agent service. I uninstalled it and installed it fresh from the update directory and tasks were going again.

1 Like

This actually all started happening (problem wise) when the erpadmin password got changed (accidentally from what I am told, and when they tried to change it back to the original password it didn’t help)

I have tried restarting I believe but will try that again…I know that when we had the password issue we updated the Logon Credentials…

Ok Thanks Greg I will give that a go (will try it on the test database first) and see if that gets me going!


You’ll need to update the password in the System Agent. We don’t run our task agents as the admin account. We have a dedicated user for the task agent. Allows us to change the admin password without breaking the task agents.

1 Like

Lets take a step back … Is all printing broken? Or just emailing?

Hi Calvin

So it was a big kerfuffle when it all happened…everything stopped working as the erpadmin password was changed (no one in IT can tell us why which is another issue ha ha). We got all the services back up after updating the password (In a million different spots it seemed) and everything was fine for a week or so. Then the emails stopped firing. We are now at the point where any email that is being sent through a BPM widget is good (after we changed it from Async, to Sync. Any that are set to Async go into Queue) But anything that is being sent through tasklists/workflow groups (specifically problematic anything coming from engineering workbench) is just ending up in the Ice.MailQueue table and not sending…

The other thing to note is that when we do a back up of live, and restore it to the test environment, ALL of the queued emails send as soon as test is up and running…

In the event viewer on the server is there anything in the App Server or Task Agent logs?

1 Like

Same user and password used for the various elements in the Test and Live Apps in EAC?

What about user privileges for c:\inetpub\wwwroot on the app server? Maybe the folder for your Test environment has different security settings than the one for Live.


Maybe even something in IIS

I don’t see any difference in the user names or passwords…

everytime I try to view the log file in the event viewer I get a snap-in Unavailable error and it shuts down…interesting

Our setup is not the standard - we use Windows binding. So there are a lot of places the user\password has to be set right.

In the App Configuration -> Application Server -> App Server Settings tab, App Pool area:

In the App Configuration -> Application Server -> Database Connection tab, its:
Windows Authentication, and the user and Password fields are blank (disabled actually).

In the App Configuration -> Application Server -> Admin Console tab, its:
Epicor Username is blank, Password has a 7 character entry (it’s masked, but is probably manager and not used)

Reporting services tab also has Windows Authentication, and the user and Password fields are blank (disabled actually).

In the Task Agent Service Config

  • The agent for our Live App has UserID print with a 5 character password (masked, I’m guessing it is print)
  • The agent for our Test App has UserID print, and the password is blank
  • both use Windows as the bindings, so the User ID and password fields can’t even be set. I’m guessing the above values are leftover from when they were using a different binding.

The windows service ‘Epicor ICE Task Agent’ (on the App server) , uses a specific account for Log On. It’s the same account specified in the App Config

They’re using the same password. I just think the windows dialog purposely shows more masked characters than there actually are.

In E10, we have a user with the ID print. It has no values for Domain or Domain User ID (which are required if you use Windows binding and want to login as this user). The user print does have
Allow Session Impersonation enabled.

The important thing, is that the user ID (for the App config and the Task Agent service) are set to never expire.

I was just running into this yesterday. It’s probably a bad custom view. delete (or rename) the XML’s in:
%ProgramData%\Microsoft\Event Viewer\Views\

So everything matches except for this one - Admin console has a manager user name along with a masked password…should the user name be blank?

there was only one XML file in the Event Viewer folder (none in Views) and I renamed it…still the same error…having IT take a look at it but not a good morning so far!

Appreciate all the input though guys, you have already been more helpful and offered more suggestions than the Epicor support…they just said I need to update to the newest version of Epicor…:neutral_face: Not very helpful ha ha