The type or namespace name 'QueryExecutionDataSet' could not be found

What have I done now?..

I had followed Jose’s excellent video on calling BAQ’s from code and had it working. My system got munged and I had to start over. Did the exact same thing. Now after I select the DynamicQuery adapter in the customization wizard. But when I go into the assembly reference manager all I see is:

image

Ice,Contracts.BO.DynamicQuery Not Ice.Adapters.DynamicQuery.dll. I tried to load it manually and it said it was already referenced. But when I compile my code I am getting:
Error: CS0246 - line 99 (839) - The type or namespace name ‘QueryExecutionDataSet’ could not be found (are you missing a using directive or an assembly reference?)

Any guidance would be appreciated. Thanks

The Ice.Adapters.DynamicQueryshould be in that System Assemblies folder. I’ve had this issue before too. Have you tried restarting the form/customization?

Yeah. Tried a restarting customization on existing form, I tried a new customization on a new form, I tried it on a different instance(pilot), I tried rebooting. Nothing has fixed it.

Do you see the Ice.Adapters.DynamicQuery in the system assemblies?

Can you educate me on what a Systems Assemblies folder is?

Yes… image

Can you post your code?

Try adding Ice.BO. to QueryExecutionDataSet when you’re initializing:

Ice.BO.QueryExecutionDataSet qeds = dqa.GetQueryExecutionParametersByID(baqname);

1 Like

Just going to reply, before I posted my code I wanted to re-review to make sure I hadn’t done anything obvious and in doing so I saw I had missed that. I added it and was able to compile. Thank you so much for your help.

1 Like

I had the same missing references and I found that when you go to the “Custom Assembly Reference Manager” you have to change the file filter to “All files” so it will show the Ice.Contracts.BO

Make sure you select the one with .dll as the file extension