UD field not saving as an editable text field (reverts to read only)

Good morning all;

I have add a UD field to Request Entry in the Maintenance module, where I want the user to enter their name. I set to enabled and Read Only = false, however, it converts it back to a read only field. I have tried to use the Wizard to set Read only to True, but it is not working. What am I missing, or is there a different way of going about it?

Thanks for any suggestions!

just curious…does it work anyhow? Are you able to write in the field despite that fact?

No it comes in as a grayed out field and will not let us edit the field.

Is the whole form grayed out? or just this field?

i don’t have the ability to look at E9 but I did exactly what you are trying to do, force an employee making the request to enter their ID… I created it back in E9, migrated it to 10 and looked just now and oddly enough those fields are set to readonly = true (never noticed) they still are and they still work… creepin me out a bit. I used MaintReqView.ShortChar01 & 02

Hello, Carol.

  • Is the UD field set to “read only” in extended UD maintenance? If so, uncheck this, regenerate the data model and reset your application pool.

  • I’m assuming you mean you’ve used the wizard to set the fields ReadOnly status to false. Double-check in the script editor to make sure that you do not have multiple off-setting lines of code in the SetExtendedProperties method that would set this back to true.

  • As an absolute last resort, you should be able to set the IsEpiReadOnly property on the custom control to false on any methods that seem to be undoing your read only status. You’ll have to be very careful with this, as you’ll need to account for clearing the screen, creating new, closing the form, etc.

Just this field is grayed out. I did come up with a work around. I created a BAQ (listing Active employees, so that they can select their name and not have to type it). Bound it to a UD field in the MaintReq table, then I had to go into Extended Properties, set the Zone BAQ on the UD field.
The only drawback now is, because I want it mandatory, and I have set the UD field to mandatory, the error box pops up with “ShortChar05” is required. I do not know how I can change the verbage to: “Must enter user name”.

When you were back in E9, how were they able to enter their name (I am using ShortChar05), which is not set to read only in Extended properties. Comes through grayed out no matter what I try. Using a BAQ and BAQ zone in extended properties is the only solution I have found.


very…i can’t say since it’s been years when i built that solution in 9.05.700C (bug in your version?) I used ShortChar01 for them to type their employee ID in, did a look up using empbasic search adapter and populated 02 with their name. It just worked…


You could make the UD field not mandatory, then add a data directive on the update of the table that throws an exception if the field is empty. You’ll have control over the text in the exception.


Thank you … that may be a possibility. I’ve never used a data directive, but will look into it.

Certainly appreciate the suggestion.