Updatable Dashboard Not Saving

I have an updatable dashboard that previously was working fine. Now, about a week after we went live it stopped saving. When they try to save it shows saving data in the bottom left but will not actually complete the action. We left it for over an hour and it did not save. when we try to go to a different tab while it’s saving this error comes up.

I also tried the multithreaded save and got this error message which seems to give me more info but I don’t know what to do with it.

I have encounter this a few times after editing the BAQ. My situation involved the Updatable BAQ Method Directives behind the updatable BAQ being deleted. I used a backup to export & re-import BAQ to restore the missing directives.

Craig Dzierwa
ERP Project Manager

Direct Line: (847) 583-4912
Fax: (847) 470-0420
7707 N. Austin Avenue
Skokie, IL 60077

That appears to be what happened but I don’t have any backups of the newest version we use.

How would I fix this if I don’t have a backup?

If you modify the BASE you’ll always run into this issue. Any custom code needs to be placed in its own directive.
If you don’t have a backup you’ll have to rewrite it :frowning:

Is it from that custom action I put in there? I never ended up making it to do anything so I could remove it. I also never made changes to the BASE.
Or is it because I added customization code to the dashboard?

If you didn’t make changes to the base you can just uncheck updatable, save and then recheck and save. The base will be recreated.


1 Like

That seems to have fixed it! Thank you for the help.