Web Services/API Documentation

We looking to inegrate some software with Epicor. The softare company is asking for Web Srvices/API documentation so they can see if it will work with their system. Where can i find this information?

I would start with the REST Technical Reference Guide on EpicWeb.

Mark W.

Where is that at in EpicWeb? I did a search and found nothing on these lines.

@Mark_Wonsil I found an Implementation guide, but not a technical reference. I am assuming the tech reference would be like this API does/affects this. Correct?


Yes, this is with the other Tech Reference Guides. Not sure why Implementation in the name other than this is how Epicor implements REST/OData.

Mark W.

@Mark_Wonsil Is there a guide for 10.1.500?

No. 10.1.500 was a technical preview although fairly complete. The first supported version was 10.1.600.

Mark W.

So, I would need to upgrade to 10.1.600 in order to use rest then, correct? If so, is there a guide for that or is it the same as 10.2?

There’s only one guide but gist is similar. You can still use REST in 10.1.500 but it’s not an officially supported version.

Ok, that sounds interesting. I tried doing seomthing liek this in Postman https://server name/ERP101500/2017R/api/v1/Erp.Bo.SalesOrderSvc/SalesOrders?$filter=372984$expand=OrderDtls/OrderRels

And getting told the resource could not be found. HTTP 404. That is what makes me wonder that I either have the line wrong, or it is not available in 10.1.500.

I recommend starting easy before going into a big hairy example like that.

Do you get anything at https://servername/ERP101500/api/help ?
or https://servername/ERP101500/api/v1

The other thing is do not forget the BAQ version of the call. If you create a BAQ with a parameter, you can call the BAQ with parameters and just retrieve the columns you want. It’s more resilient to BO changes too.

Mark W.

Yeah, I tried the easy one earlier. Got Server Error in ‘/ERP101500’ Application. The Resource cannot be found.

So you have some setup work to do first… Check out Bart’s REST Novella thread. Lot’s of info there as most of it was written during 10.1.500.

Well, I got it to work till http://servername/ERP101500, but when I add the /api gives me the error, HTTP Error 404.0 Not Found

Did you see @Olga’s message?

Yes, I did. Makes sense. To be honest, I am not sure what to look for in the Web.config.

Fixed! Got it working. I rebuild the appserver and that fixed it!

1 Like

I am Unable to download this PDF or access. It’s need Login. How ?

You have to login into EpicWeb. Do you know your login credentials?