Barcode Font Code 39 Azalea Regular not showing

Good afternoon all,

I have a unique problem with Barcoding showing on an SSRS report, Job Traveler.

  1. I added the Font, Code39AzaleaRegular3 to the Report Server, SQL server as well, and for good measure to the Application server as well.

  2. Restarted all of the servers to activate the new Fonts.

  3. I print previewed the Job Traveler in PDF and the bar code doesn’t work. The field shows like ‘*123456 *’

  4. Ran the report in Report Builder using the GUID and the bar codes show on the Job Traveler in Report Builder. That tells me the Server has the font.

  5. I tried printing the report to see if the Job Traveler would print the bar codes and no dice, same outcome ‘*123456 *’.

  6. I even tried adding the font to my computer, just in case, and no joy.

The barcode is the standard Fields!Calc_BCJobNum.value, so not a custom.

Has anyone run into this issue before? If so I would appreciate a walk through on your fix.

Thank you,

Jonathan Lang

P.S I know it’s a PDF problem because the bar codes do come through on Microsoft Word. Which is not ideal since Word adds an extra page between pages and the alignment is off.

Some barcode fonts want the string enclosed in ‘*’, so


It does have the ‘*’. I put double quotes not single so it doesn’t show on the post.

I know! I had to use the code sequence to send it to you! :rofl:

Ok, just checking…

just guessing, but does the workstation that the PDF is being viewed on have the font installed?

It does, but that shouldn’t be an issue since it’s SSRS not Crystal Reports. But yes, just for giggles, I did install the font on the client.

If you view the details of the PDF (somewhere it lists the fonts in use), does that font show up?

P.S. - do barcodes show on any other reports? And if so do they use the same font?

How do you see the details of the report? Do you mean open with Notepad++?

Nevermond, I found it:

FWIW - We uses DataWorks Bar39 for ours


Does the font you’re using have Human Readable text too? Any possibility that the field size on the report is clipping the barcode, and you only see the Human Readable part?

Nope, I reduced it to Font 12 and still no luck. We don’t have DataWorks, but I can try it. I’m not sure it will make a difference. None of the other Bar Codes fonts work in PDF.

And FWIW the screen shot above was taken on a Client that does NOT have the DataWorks font installed (but does have 9 different variants of Code39Azalea installed)

That’s correct If you’re using SSRS. Only your Report Server needs the font.

1 Like

So to circle back around … Viewing the Report in SSRS builder (in Run mode), and the barcodes appear. But previewing in a PDF they don’t.

I know the SSRS Builder allows you to export a report after it has been run. Is PDF one of the export options? If so, export it then view that PDF on several different machines.

Yes, that works. I can see the barcodes when printing from Report Builder to Adboe PDF, but not from Epicor to PDF.

You’ve enabled BarCodes in Company Config, right?


Does anyone have a Dataworks Bar 39 Font or a link I can grab it from? It’s DWBAR39.ttf.