BPM Designer freeze up on custom code

This has been happening for quite a while, since at least 200, but it seems worse on 600 where you close a custom code window in BPM land and it only half closes where you can no longer interact with the BPM designer as it remains modal blocked. When you hover over the preview window on the taskbar the code window still shows, but when you actually focus the code window it’s gone. It’s a wierd thing but I think it’s happening on automatic code validation.

About one in 10 times closing the editing window it will freeze up on me and I have to task kill Epicor. In the last hour it’s done it 4 times and I keep losing my work.

Anyone know how to reproduce on command that I can submit something of substance for a case or have an existing PRB for it?

I’ve had this too, seemingly random but most annoying. If I can nail it down to a specific circumstance I’ll chime back in.

At first I thought it was if you made no changes and tried to close, but that was not it. I have been copying and pasting from one code block and bpm to another deploying a function in many areas. So I think I’m on the right track as it’s especially bad right now.

I’ve not seen this in a while, but did experience it on 10.1.400. I attributed it to something wonky on my workstation.


see this topic

Whenever I use a code block I’m always copying in from a text file (I save and reuse/recycle past snippets and update). Perhaps that is a clue… but I’ve had other times when it was no problem. It DOES seem to be only on 10.2.600… I have a client on 10.2.500 that hasn’t burped on me this way yet (but the 10.2.500 is on-prem and all the 10.2.600 folks are SaaS (DT)).

For sure it started happening for my on 200 but it was a rare annoyance there.

I always run into a problem when I am in customization mode, forget to turn it off, and go to edit a BPM with a custom code widget and it crashes. Sometimes it won’t crash but eventually ends up hanging and causing me to lose code. Not sure if related but just another annoyance - or user error :slight_smile:

Are you sure that the “This isn’t customizable” window isn’t popping up behind another form?

The crash - no. The application actually just shuts down. The hanging doesn’t have any hidden windows in the other scenario.

1 Like

I have had several support cases submitted that we’ve tried to figure this out. It even happens to me sometimes on the SQL editor in BAQs.

I always clear out the BP*.dll in my cache directory before I start editing BPMs.

Support seems to think it’s a mismatch between the .NET client on my computer versus the .NET that Epicor uses. It is entirely random, and I’ve never been able to reproduce it. Although it always seems to happen right when I finally figure out how to do something that solves my problem. I forget to copy/paste into Notepad++ and then boom, I lose it.

I’ve even gone so far to take a snapshot of the screen (hovering over preview) before killing the Epicor process in order to get the code snippet that I had just worked on.

This started for me on 2.400

I’m inclined to think it’s the switching between a winform, wpf forms (bpm flow designer) but who knows.

customization mode and switching btw 2 companies – crashes epicor for me – w bpm script editor