Closing a job "A labor detail record is either active or has not been approved."

Operation complete just has to do with whether or not all of the quantities are complete, or if someone marked it as complete. It doesn’t have anything to do with whether or not they are still clocked in.

thank you, so by clocking him out, the job completed yet the “Completed Qty” is still zero, is that OK?

Yeah, they have to put how many they completed to get a quantity. That’s on the end activity or in the labor detail record. You can clock in and out of something without actually completing any.

So they have to put in how much they completed on their clock in/out or on the job itself?

Yup, how else would the computer know?

thank you so much, so now I have green checks in all my operations, but I am still getting the same error. Under Materials, I have red dot’s, is that an issue? I am sorry these might be dumb questions, but I feel like the guides are missing a lot and the prior contractors we had, showed us little.

What error is that?

A labor detail record is either active or has not been approved.

Are all of the labor transactions in that list approved? Go into time and expense and find the details. Depending on if you have auto approve set or not, simply clocking out may not approve the records.

Try this:
Enter the job number on the Job Status dashboard, and retrieve data.
Check the LaborTrans for the employees who worked on the job. Take note of the Employee ID and Clock In Date.
Open Conversion WorkBench > User Run Conversions > End Activity On Active labor Transactions Process (630).
Enter each Employee ID and verify if there are Active transactions.
Go to Time and Expense Entry, enter the Employee ID and select the ClockInDate from the calendar.
Expand each dates from the treeview. There may be time details that were “entered” (letter E on the treeview) but not yet Submitted. If this is the case, Submit it.
Go back to the Conversion workbench and refresh the employee’s transactions.
Select the Active transaction, then Submit.
Also check from Conversion WorkBench > User Run Conversions > End Activity On Active Labor Header Transactions Process (660).
Verify each employee and close any active labor transactions.
Go to Job Closing to close the job.

sorry Art, you logs me at the conversion workbench, User Run Coversions, I dont have an Evd Activity on Active labor, still running into this issue

You can look in job tracker under the labor details and look for ActiveTrans = true or Labor Status = E (you want A) That’s usually how I find them. Then just go to time and expense and fix from there.

You should log in as system manager.
Conversion Workbench can be found in System Management > Upgrade/Mass Regeneration.
Or, you can do Search.
Select User Run Conversions. Select 630 - End Activity On Active Labor Transactions Process.

Goto the menu Actions and select Run Pending Conversions.

I should add. Even though I have a BPM to stop it, somehow people can still occasionally get clocked out for the day with an active trans on a job. If that’s the case you have some UBAQ or database hacking to do to get it corrected. Until the trans Isnt’ active you can’t see it in time and expense to fix it.

maybe i am missing it, where is labor details

I just did all that, and selected both 660 and 630 since you mention both in the picture and got this, so I wonder at any point, does Epicor become usable?

Program Ice.Services.Lib.RunTask raised an unexpected exception with the following message: RunTask:
System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at Erp.Internal.Conversion.CVJC0078.convertData() in C:_releases\ERP\ERP10.2.700.0\Source\Server\Internal\Conversions\CVJC0078\CVJC0078.cs:line 62
at Ice.Core.TaskBase`1.StartProcess(Int64 instanceTaskNum, String outputFileName) in C:_Releases\ICE\ICE3.2.700.0\Source\Server\Internal\Lib\TaskLib\TaskBase\TaskBase.cs:line 83
at Ice.Hosting.TaskCaller.InnerExecuteTask(IceDataContext newContext) in C:_releases\ICE\ICE3.2.700.10\Source\Framework\Epicor.Ice\Hosting\TaskCaller\TaskCaller.cs:line 117
at Ice.Hosting.TaskCaller.ExecuteTask() in C:_releases\ICE\ICE3.2.700.10\Source\Framework\Epicor.Ice\Hosting\TaskCaller\TaskCaller.cs:line 59
at Ice.Lib.RunTask.BpmFriendlyTaskLauncher.Run(String sessionIdPrefix, IceContext db, Action taskRunner) in C:_Releases\ICE\ICE3.2.700.0\Source\Server\Services\Lib\RunTask\BpmFriendlyTaskLauncher.cs:line 63
at Ice.Services.Lib.RunTaskSvc.InnerRunTask(Int64 ipTaskNum, Boolean suppressTransaction) in C:_Releases\ICE\ICE3.2.700.0\Source\Server\Services\Lib\RunTask\RunTask.cs:line 454

Holy crap that’s a lot of operations to check labor details for. I would stick to the dashboard @Banderson mentioned or use a custom BAQ. I have one called “Fix Stuck Labor Records” we get a lot of people stuck in downtime.

yeah, I have done that, and days later, I am still still here trying a ton of different things

Try this one
WCI-FixStuckLaborTrans.baq (49.9 KB)

Sorry, as frustrated I am right now with every bit that is Epicor, I hate it with a passion, I wont use a BAQ, it won’t teach me anything. Thank you though.