Customization layout keeps reverting to first save


I have created a dashboard, deployed and added to menu as Dashboard-Assembly.
I created a customization to add some buttons and textboxes.
It looks fine when I saved it. I closed the screen and changed the menu to use the customization.
I logged out of Epicor and logged back in. Checked and looked OK.
Later on (weeks later) I needed to revisit the screen and change some layouts on it.
I saved the changes and backed out of screen. When I went back in, it had my changes overlapping the original look. I cleared the client cache, deleted the folder in C:\ProgramData\Epicor and even rebooted my PC for fun.
Went back into the screen and it still is a mixture of old and new. Redid it again, same result. Totally rebuilt it manually to just the new changes, still shows the mixture. Changed the dashboard and deployed it again. No help.

I am not sure where it is holding it or how to get rid of it. Any help is appreciated.



Update on what I have tried.

  1. I have deleted the customization after backing it up, no help.
  2. I have deleted and rebuilt the menu item, no help
  3. I have modified the dashboard and redeployed it, then built new menu item, no help.
I am about at my wits end!

My next 2 things to try are: Build a new dashboard and deploy it or figure out how to delete the current dashboard DLL and redeploy.

Anybody have any thoughts?

Unless there is a better way, I had to totally delete the customization, menu item and dashboard. Then rebuild from scratch.

Maybe someone knows a better way?

Did you delete the personalizations on the form?

Goto c:\programdata\epicor\customers and delete the Dll then redeploy


I’ve seen this “deployed dashboard - seems to revert to previous version” issue several times in this forum.

some answers simply state - clear the client cache - and others go as far as to recommend - delete the entire code and start over.

this isn’t social work. it’s not a subjective mattter.
isn’t software engineering supposed to be a scientific endeavor?
wtf is it seemingly impossible to confirm what the problem is or how it specifically needs to be fixed.

really, is this software environment really so screwed up that any scientific approach is doomed?

just saying… :slight_smile:

This is what I do that works every time for me.

Thank you for the help.
My challenge is the EMS/parallels environment which doesn’t provide me access to those file areas.
but sure as “wet-snow-in-april” I will try and confirm back.