Old Dashboard shows after updates and re-deployed

Created a dashboard, deployed it, and everything was fine.

Made some changes to the dashboard, and did the deploy thing again. But the original dashboard still shows.

What simple thing am I missing?

EDIT: BTW - this is an Updatable Dashboard

I may be WAAAAY off here because I don’t deal a lot with Dashboard creation and deployment but whenever we’ve had problems with a Dashboard not opening for a user, or not updating with changes, we would go into the C:\ProgramData\Epicor\epicor1-9401\9.05.702\WDI\Dashboard folder on the server, or user’s PC with the issue, and rename\delete the .dbc file (I believe this is safe to do as I think this is only a temp file that gets regenerated every time a Dashboard is opened). This always seemed to work for us in our E9.05.702 - Progress - environment not sure if that Dashboard folder even exists anymore in an ERP10.1 SQL environment?

I was just about to post that I found copies of the DLL.

But these are on my client. I don’t expect each user to have to go in and fiddle with files on their machine.

And I assume the differences (lack of DBC files) is because I’m on E10

I renamed Ice.UI.App.ck_Prod_Label.dll to Ice.UI.App.ck_Prod_Label_orig.dll
and Ice.UI.App.ck_Prod_Label_1.dll to Ice.UI.App.ck_Prod_Label.dll

That looks like it worked.

Now how to get that to happen automatically on each clients system?

Hummm…no I wouldn’t expect each user to have to do that either.

Has another user tried the Dashboard and can they see the updates you’ve made or are they still seeing the old one too? If they still see the old one then I’m assuming it goes back to the deployment process and something missing with that…

Yea, they might have gotten rid of the DBC files in E10…I guess it was a shot in the dark. I’m sorry that wasn’t the answer…

I don’t think I’ve ever had an instance where restarting Epicor did not get the updated version, but you can also try to clear the client’s cache.


Not sure on 10, have not checked, but if you updated the name of dashboard you may have to update the new .dll assigned in Menu Maintenance under the dashboard drop down.

1 Like

REALLY!? Interesting…and rather unnerving that you would have to do that. I wonder what part of the deployment or Dashboard creation process creates those .dll files and why it wouldn’t be updating them?

We have good results by recycling the application pools on our applications servers.

1 Like

If your dashboard is deployed as an assembly and not a runtime you need to
redeploy the dashboard after you make changes on it in order for the user
to see the changes on the menu

Mark Wagner
Sr. Partner

Capstone Alliance Partners 888.597.2227 Ext. 71
<888.597.2227%20Ext.%20714>2 | 904.412.6847 mwagner@capstoneap.com (cell)
| www.capstoneap.com

1 Like

I had experienced same problem with newly deployed dashboard. After making some changes, i re-deployed it, but the previous dashboard was still exists.

I deleted that Dashboard Menu item from Menu Maintainance and depolyed again. It worked fine.

I had similar experience with dash board deployment. I am suggesting : 1. Clear client catch, 2. Make fresh login to Epicor 3. Open it from main menu 4. if you have favorite, recreate it. This seems always working well for us.

The issue can be solved by deleting the personalization or deleting the menu:

  1. Delete the personalization if it exists. Clear the client cache If necessary.
  2. If (1) did not work, delete the menu, clear the client cache, open a new Epicor session and add the menu back.

I hope that helps!

The issue can be solved by below steps:

  1. Redeploy the dashboard.
  2. Clear the client cache.
  3. Logout from Epicor.
  4. Login to Epicor.
  5. Open your dashboard.

I hope that it helps!

1 Like

Hey @Hari_Dutt and @AIMDev, this thread is two years old and the question has already been answered. I think we can move on from this one.


Solution does not work in Epicor10.2