Error- End of Central Directory record could not be found

ERP11.2.100.9

I was recently made aware of the functionality to edit reports utilizing the “SSRS Report Design” in Epicor via Knowledge Article EpicCare Login - EpicCare.

I followed the instructions -

  1. set user to edit SSRS reports.
  2. Opened Invoice Tracker - an available Invoice
  3. Chose Print
  4. Chose my custom made Report Style
  5. In the "Print Invoice screen, I select “Generate For Design”
  6. In System Monitor I select the record and “Design SSRS Report”
  7. I save a copy of the report definition to a Desktop folder
  8. The ARForm report opens in Report Builder
  9. The first step is to alter the footer area to match my E10 report

That save and executes just fine.

It is a combination of textboxes and jpeg graphics.

Works exactly as I expected.

Next I go to work on the Header.

I clear out the company address to make way for my logo.

That executes fine, too.

Then, I Insert Image of the same jpeg I’ve been using in ARForm for years in to the Header area and I get an error:

I don’t know what this means or how to fix it.

Error- End of Central Directory record could not be found.

Please help!

Ben

System Information

==================

AppServer Connection: https://DSEPICORAPP11.XXXXXXXXXXl/Kinetic2022_1
Form Name: SSRS Report Design
Customization Name:
Menu ID: XAPR1009
Software Version: 4.2.100.0

============

Server Side Exception

End of Central Directory record could not be found.

Exception caught in: Epicor.ServiceModel

Error Detail

============

Description: End of Central Directory record could not be found.

##!Correlation ID:##! c7ac892a-c501-4d21-a36f-828676135a75

Client Stack Trace

==================
at Ice.Cloud.ProxyBase1.CallWithCommunicationFailureRetry(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, RestRpcValueSerializer serializer) at Ice.Cloud.ProxyBase1.CallWithMultistepBpmHandling(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, Boolean useSparseCopy)
at Ice.Cloud.ProxyBase`1.Call(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, Boolean useSparseCopy)
at Ice.Proxy.BO.SsrsReportDesignImpl.UploadAndRenderDesign(Guid sysRowID, Byte[] compressedReportDefinitions, String outputFormat)
at Ice.Adapters.SsrsReportDesignAdapter.UploadAndRenderDesign(Guid sysRowID, Byte[] compressedReportDefinitions, String outputFormat)
at Ice.UI.App.SsrsReportDesign.Transaction.UploadAndRender()
at Ice.UI.App.SsrsReportDesign.ReportDesignForm.BaseToolbarsManager_ToolClick(Object sender, ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.ToolClickEventHandler.Invoke(Object sender, ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.OnToolClick(ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.FireEvent(ToolbarEventIds id, EventArgs e)
at Infragistics.Win.UltraWinToolbars.ToolBase.OnToolClick()
at Infragistics.Win.UltraWinToolbars.ToolMenuItem.OnClick()
at Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.DoClickProcessing(MouseEventArgs e)
at Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.OnMouseUp(MouseEventArgs e)
at Infragistics.Win.TextUIElementBase.OnMouseUp(MouseEventArgs e)
at Infragistics.Win.ControlUIElementBase.ProcessMouseUpHelper(Object sender, MouseEventArgs e)
at Infragistics.Win.ControlUIElementBase.ProcessMouseUp(Object sender, MouseEventArgs e)
at Infragistics.Win.Utilities.ProcessEvent(Control control, ProcessEvent eventToProcess, EventArgs e)
at Infragistics.Win.UltraWinToolbars.PopupControlBase.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I get the exact same message. I do not have to do anything. Just do the download and then preview.

Error message.

DaveO

This has something to do with JPG’s. When I delete just the corporate logo jpg it previews fine. If i try to put it back in it errors out.

I tried saving the jpg as a PNG - no luck still get the error.

Note: If i leave the JPGs in the report and manually upload it and run it - it prints fine. It looks like a something to do with preview function in ssrs designer?
DaveO

1 Like

Yes, I confirm the same sequence of events.
When I added the image file, all my trouble starts.

But, yes, the definition runs after saving it with the image file.
Just no preview.

Makes editing the report not fun!
Ben

I have done a little more testing on this issue. I found that by reducing the size of a couple of my images i could get the report to show without error.

At First i thought this was related to one Logo that i had imported because if i deleted the image the report worked. I tried multiple types i.e. BMP, PNG, JPG all with varying settings for quality.

in the end i reduced all my images (mostly signatures) to 96DPI as JPGs saved for Compression size with made them all about half their size and I now have all my images and they work.

I tried searching Report Builder Image Size Limt - however, it did not help - but this sure feels like some kind of size limit for images.

Maybe you could try the same? (or already have :slight_smile: )

DaveO

2 Likes

Dave,

Did you look at the images section of your RDL?

Is there more than one embedded image?

I noticed that if you re-import or delete the image from your report canvas, the image file still stays there and takes up space.

image

2 Likes

Yes - I tried manually moving an image from last to first - still would not preview. My report has about 10 images 2 logos and 8 signatures

1 Like

I see!

I came across this same error message today and can confirm that removing any images shown under Report Data → Images that were no longer in use did indeed fix the issue.

Thanks @utaylor

4 Likes

I ran into this error with a cloud client upgrading to 2024.1.
First the report was erroring out due to a missing field, which I found wasn’t needed, so I removed it from the query and the field listing and confirmed it was not referenced in the report anywhere. After uploading via Report Style Maint, now I get this error.
So after seeing this post I checked for any images and I found two noted but not used so I removed them, uploaded and attempted to print preview or print and I still get the error. Anyone have additional insights on this?
I saw another post about getting this error when downloading the report style, but I can download it fine, just when trying to print or print preview.

Not sure Rick

Are you downloading/ uploading via Classic or Kinetic? I was getting the same error on a SubCPack report when downloading and uploading the .rdl via Classic, but when I downloaded and re-uploaded the same report style within the .zip file generated from Kinetic, the report generates and previews as expected.

9 Likes

@dylanb
Yes, that was either it or part of the issue anyways, but in the process of troubleshooting this I ended up cleaning up many of the SSRS queries and removed any old references to images as previously suggested.
So what appears to have happened is that after the Pilot environment was refreshed with Live (latest RDD) and upgraded to 2024.1 they found that the Job Traveler was not working in Pilot since the SSRS reports did not align with the RDD so they attempted to download the Live SSRS report via Classic (I assume) and upload them into Pilot via Classic (I assume).
But when I did everything I could think of I kept noticing the reference to a zip file in the error message and I remembered that the Kinetic version downloads to zip and uploads a zip…so I zipped my latest version and uploaded it and bingo it worked!
So I wonder if this means at 2024.1 it’s best to just switch to Kinetic for Report Styles?
But you get the credit for beating Epicor Support to a solution.

4 Likes

Very kind complement @dylanb .

This problem started for us yesterday when Cloud team upgraded our Third environment to 2024.1.8. They have stated it’s a known problem linked to Problem Number: PRB0284786

We must be on the same cadence, our pilot is 2024.1.8 and they also gave me PRB0284786 which is currently in testing.

I am told from our PM that it was a botched upgrade and it is only affecting a subset of Cloud hosted servers

2 Likes

Gosh darn it, I just spend a good amount of time trying to figure out what I was doing wrong. Maybe nothing it turns out.

1 Like

Yeah, with all your fields missing, we know yours was botched.