End of Central Directory record could not be found after upgrading to 2022.2

Since we upgraded to 2022.2, I am unable to use the Download for Design process on any of my custom reports that contain images. When I use either the preview or the publish command in the Design SSRS dialog, I get this error:

Server Side Exception

End of Central Directory record could not be found.

Exception caught in: Epicor.ServiceModel

Error Detail

Description: End of Central Directory record could not be found.

Correlation ID: a8e6e1e1-ee4c-4edb-9c78-8155ad2703dd

Client Stack Trace

at Ice.Cloud.ProxyBase1.CallWithCommunicationFailureRetry(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, RestRpcValueSerializer serializer) at Ice.Cloud.ProxyBase1.CallWithMultistepBpmHandling(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, Boolean useSparseCopy)
at Ice.Cloud.ProxyBase`1.Call(String methodName, ProxyValuesIn valuesIn, ProxyValuesOut valuesOut, Boolean useSparseCopy)
at Ice.Proxy.BO.SsrsReportDesignImpl.UploadAndRenderDesign(Guid sysRowID, Byte[] compressedReportDefinitions, String outputFormat)
at Ice.Adapters.SsrsReportDesignAdapter.UploadAndRenderDesign(Guid sysRowID, Byte[] compressedReportDefinitions, String outputFormat)
at Ice.UI.App.SsrsReportDesign.Transaction.UploadAndRender()
at Ice.UI.App.SsrsReportDesign.ReportDesignForm.BaseToolbarsManager_ToolClick(Object sender, ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.ToolClickEventHandler.Invoke(Object sender, ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.OnToolClick(ToolClickEventArgs e)
at Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.FireEvent(ToolbarEventIds id, EventArgs e)
at Infragistics.Win.UltraWinToolbars.ToolBase.OnToolClick()
at Infragistics.Win.UltraWinToolbars.ToolMenuItem.OnClick()
at Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.DoClickProcessing(MouseEventArgs e)
at Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.OnMouseUp(MouseEventArgs e)
at Infragistics.Win.TextUIElementBase.OnMouseUp(MouseEventArgs e)
at Infragistics.Win.ControlUIElementBase.ProcessMouseUpHelper(Object sender, MouseEventArgs e)
at Infragistics.Win.ControlUIElementBase.ProcessMouseUp(Object sender, MouseEventArgs e)
at Infragistics.Win.Utilities.ProcessEvent(Control control, ProcessEvent eventToProcess, EventArgs e)
at Infragistics.Win.UltraWinToolbars.PopupControlBase.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Support originally connected my case to an existing PRB, but that PRB is for large images. My images are not large, and even when I completely delete the image control from my report, I still get the error. Nothing but silence on this from support for almost a month now (yes I escalated it, still no response at all from the tech or from support management).

The commonality I see in the reports that are failing is that I am using a database image from the filestore. Is anybody else loading their logos this way and running into any similar problems or have an idea how to fix it?

The reason we don’t just plop the logo onto the report directly is because each company has a different logo and its a lot cleaner to just load the logos into the database and have the correct one dynamically loaded to the report, than to have all of them on the report to begin with and then visibility rules for each one. At least I thought it was until I upgraded and it doesn’t work anymore.

This is definitely not an issue with the rdl because if I go into Report Style and upload the file it works fine. It seems like a bug in the Design SSRS program.

I do frequently run into this same error - and it’s always seeming to be image related.

Just deleting the image from the design canvas isn’t enough, in the tree on the left remove it from the Images too. Usually that will let you preview and upload again.

I’m usually doing embedded - and sometimes just re uploading resolves it, sometimes changing from jpeg to png.

We definitely need a fix from Epicor for it, because the Design SSRS functionality is great apart from that.

My images are dynamically loaded so I can’t remove them from the report unless I delete the whole dataset (nor would I want to). Very frustrating. Do you know if there is a PRB for this issue? The PRB I was given specifically refers to “large” images so it doesn’t seem relevant.