Industry Extensions Framework installation on 10.2 Errrors

Anyone been able to successfully install IEX Framework on 10.2.100?
There is no installation guide.
The installation exe seems to only create the menu items, but does not copy the required DLLs to appropriate folders.
I had logged 2 support calls that have appeared to gone into File 13.

How did you eventually get this fixed?

Probably reinstall IEx and ACH from EpicWeb, they do have it looks like a 10.2.x version, then add the CSG Folder to your web.config and restart IIS

You have to click on the + and then pick the Language.

1 Like

@tomdomurat - We just went through this yesterday. I can give you a name to call directly and talk to him about it. We’re going from 10.1.500.17 to 10.2.300.6 and he says that all of the IEX is BUILT INTO the release so we do not need the IEX at all. I’m not sure about 10.2.100 of course, but .300 has all my stuff built in.

I hammered on that thing for a week only to call for help - but since I already have a CSG customization in IEX they were quicker to respond.

Hope that helps.

Send me the name too… Oddly ACH is still an IEx I didnt see ACH built-in… any info on that? @MikeGross

@MikeGross Also we were encouraged to go back to Crystal for MICR - wtf.

Hmm, I see ACH in 10.2.300 under Payroll_NACHA but I don’t see a Bank Payment ACH type - although ACH formats being ‘standard’ and all, that should work. Sorry @hkeric.wci but I didn’t ask about ACH. BUt now I’m interested b/c we want to do this in a few months as well.

I’m PM’ing the name once I notify him that I just gave him up to you guys. :slight_smile:

Found - thanks
:pensive:

@hkeric.wci - sent you a PM with his name. He’s happy to help.

If you would update this (or the other post) with your findings I think it would help us all :slight_smile:

1 Like

This is our experience since 10.2.100. All the Electronic Interface files are in the Erp\EI folder on your server (or by request if in the Cloud).

Mark W.

1 Like

With the help of @Humberto_Martinez, we were able to break through the jump from 10.1.400 to 10.2.300 generating NACHA ACH transactions to pay vendors. In 10.1.400, I don’t think we defined any Electronic Interfaces and/or used defaults. In 10.2.300, we changed the “Program” on the EI from generic ach to Payment_US_ACH_Domestic.cs (path is Erp\EI\Payment_US_ACH_Domestic)

Couple of notes.

  • The PayrollElectronicDeposit_NACHA.cs will not work when paying vendors. You’ll get a cast error as it is intended to only work with Payroll. I’ll add, since I’m new to ACH, I didn’t understand NACHA. Their site is geared toward Payroll. But several of the top 10 banks accept NACHA transactions to pay vendors. The Payment_US_ACH_Domestic.cs generates the NACHA standard

  • If using Payment_US_ACH_Domestic, we then had to ensure the Suppliers “BANK” address has the country defined. I don’t think we had anything in bank address for any of our suppliers. On the transactions processed, we only changed the country to USA.

  • We also had to update Currency Master Maintenance and supply an ISO Number of 840 (in the US) and ISO Currency Code of USD

2 Likes

Nice. Thanks @Humberto_Martinez.

1 Like

Good info for the rest of us.
Thanks @svanniman AND @Humberto_Martinez !

1 Like

Great info! Someone from Epicor give @Humberto_Martinez a raise!

@tomdomurat
Probably you already solved this, but the reason for that error is because the dll is not in the right folder. A re-installation will fix it, just need to make sure that in the Solution Workbench you select the “server” deployment folder, that one is typically something like this: C:\Epicor\Websites\Epicor10Test.

Well, thought we were there… Turns out the Payment_US_ACH_Domestic.cs pulls our erp.Company.FEIN number when our bank is expecting our Bankid - BankAcct.BankCompID.

Since the file is a cs file - I found the two places where FEIN is being placed (one in line 1 and the other in line type 8 - Company / Batch Control Record.

As the code is already referencing BankAcct, the thought process would be to replace the three references of company.FEIN with bankAcct.BankCompID. I copied the Payment_US_ACH_Domestic.cs to Payment_US_ACH_Domestic_SVN.cs to ensure the changes were not over written with a point release upgrade.

Made the change to reference _SVN in the Electronic Interface and tried running, but getting Value cannot be null. Parameter name: type

image

Back to the drawing board.

Thoughts are A) to plug in our BankCompID in the the company.FEIN field, but that should be our Federal Tax Id, B) modify Payment_US_ACH_Domestic.cs - extremely dangerous or C) post process the file and replace the three locations of FEIN with BankCompID…

@Humberto_Martinez Any ideas on the previous?

I don’t think that BankCompID is the one null, if you notice it is being validated at the beginning of the method buildInfo.
The only way to fund out what the issue is, is to debug, try to force the program to debug with this line of code: System.Diagnostics.Debugger.Launch(); and go thru the code until you find the null value.