Intermec CK75 Scanner Questions

We just got some Intermec (I guess they’re Honeywell now) CK75 scanners for our warehouse and we’re running into some issues.

  1. RDP timeouts. After 10 minutes, the RDP session will disconnect. I have confirmed that the server and user are both in groups that don’t have a timeout policy. This was confirmed by logging into the RDP session as the user on my PC; it never timed out.
  2. The F1 and F2 keys are hotkeys for disconnect and full screen in the RDP client, but they are also quick keys programmed by Epicor for navigation within the handheld screen. How can I disable the RDP shortcuts?
  3. When is Epicor going to create a high res aware application so I don’t have to use an RDP client that’s ancient and pixelated? (Wishful thinking)
1 Like

Yeah we bought some because I know the value of handhelds and having the info at your fingertips, but the Epicor interface is so bad that they just collect dust now. One of these days I’ll probably try to tackle customizing them, but I haven’t gotten to it yet.

1 Like

Same deal here-- we have three CK75s and none of them are actively used because of rampant connectivity and responsiveness issues. Still trying to get them working since we’ve already sunk the money into them, but they’re a mess.

Oh boy–that’s not what I wanna hear. :worried:

Aaron,
For one client we did not purchase the CK75’s because of the resolution issue. The vendor was kind enough to let us borrow several different units so we could determine which one would work best for us. The CK3X and CK3R were selected and those units have been being used ever since they were purchased several years ago.
Since setting up handhelds is so tricky and Epicor doesn’t provide much guidance, awhile back I hacked together a setup guide:

If I recall the 10 min timeout is not something that can be fixed as I think it is a security feature baked into the Windows Mobile RDP program.
Perhaps it’s not too late to try to trade them in for CK3’s?

1 Like

Yeah, it’s too late to swap them, unfortunately.
I found an application called RDM_KeepBusy that, while not ideal, seems to do the trick for the timeout.
It basically puts a barely noticeable cursor in the upper left that blinks to keep the session active.

Now to figure out how to break the F2 binding…

@willetta

I use MS Surfaces. Refurbed they run about $500 and you can connect any scanner you like starting around $60 - they make for a great user experience.

Run full E10 client (or RDP if you choose) and it just looks great.

I think the only benefit of using the handheld software is for the limited workflow - which you can reimplement using customization.

2 Likes

We have the CK75s with Android installed. Works pretty well. The Windows platform for these is dated.

You can run epicor on android?

Brandon,

I should have been more specific. We run Android and remote desktop into a server.

Doug

1 Like

That makes more sense.

You’re still using the epicor handheld programs though right? Did you customize them? That’s the biggest problem for us in these not being usable.

Yes. We are still using the simplified HH menus. We are not big fans of these screens either.

To address someone’s earlier question about when Epicor is going to update the HH module, I heard at Insights that they will be taking their new framework that is currently being used for Mobile CRM and applying that to HHs in the near future. (Safe Harbor Statement - targeting 10.3)

1 Like

There are a few tools out there, both I believe are provided through Intermec, err…Honeywell

“KBDTools” which is a general device key re-mapper and “SR12051500_Tool_WM65_All” which is the remote desktop function key re-mapper. The latter is likely what you are looking for. For example, it will remap the function key F1 to a semicolon, RDM receives the semicolon, and then transmits the F1 key.

@Jim will Epicor running in the RDP session still recognize that I pressed the F2 key by doing the second one? I tried the first one already and Epicor would no longer recognize that I was pressing F2 after remapping.

Yes, it’ll remap one way on the client, then back again on the host. (i.e. F1 to ; to F1) However, you will have to be careful of the remap characters used. If they are contained in a barcode or input into the screen (i.e. text input contains “;”) - it’ll send the mapped F-key instead.

Search Article 000035880 on honeywell technical support portal.

@Jim, that didn’t seem to work. It still brings up that RDP bar when it’s in full screen mode.

And to be clear, it’s the red box that pops up when I hit F1 or F2.

@willetta Looks like SR12051500 cab is not installed or working correctly for you. I disabled my F1 key remapping and was able to replicate your issue.

For reference, I have the CAB file file persist on the device and is at locations at \FlashFileStore\CABFILES and \FlashFileStore\UserAutoInstall, The RDM text file is placed right in \FlashFileStore. Once installed the “Configure RemapRDM” program shows in the main start menu, open, check/remap, and save.

For testing, I suggest having a test key remapped (maybe F3) to a character and have it input in your epicor login screen to see if its working on the remote desktop.

@Jim, I have it set so that F2 is the “=” key.
When I’m in Epicor in the RDP session and I hit F2, it brings up the RDP menu.
If I hit “=”, however, it functions like F2 in Epicor.
I was under the impression that I could still hit F2 and have it accept F2 in Epicor, not remap F2 to another key, hit the other key, and have that act as F2 in Epicor.

Your impression on how it should work is correct. Did you modify both the ConfigureRemapRDM.exe and the text file?

F1 sends 0xBA semicolon
Google Photos

Text file maps 0xBA back to F1 in remote desktop (list corresponds to F-keys in order)
Google Photos