Job Traveler modification

We use UDcodes in JobHead for job code. I am trying to get the description from the UDCodes table into the Job Traveler. I added the UDCodes table to the RDD and added the table to the dataset in the RDL. When I try to run the report I get an error "Invalid object name UDCodes_#######.

I’ve tried running the report with the RDD relationship as Output and Definition. Also tried adding the table in the RDL dataset a couple different ways, ICE.UDCodes_ vs UDCodes_, also tried it with and without GUID after the table name. I keep getting the error "Invalid object name UDCodes_#######.

What am I missing to make this work?

The query cuts off, did you add the fields you are trying to access into the query as well? T6.CodeID etc…

Also, when selecting the fields in the RDD table join in the picture above, are you selecting the fields or typing them in? If they are not available with the drop down you may need to add them to the exclusion table and uncheck the exclude box.

Thanks Dan. Yes I have the field in the query. I deleted the relationship fields in the RDD and recreated them to make sure the fields are in the drop down and they are.

Perhaps this post can explain why this might be happening?

Thanks again Dan. This is embarrassing, we have two RDD’s that are named very similar and I was editing the wrong one :blush: The report is now running without errors.

1 Like