Kinetic 2023.1 - Customized forms missing Base fields (after update)

Looking for advice, I guess… SaaS upgraded our PILOT database to 2023.1.

We just went LIVE back in February, so this is our first major roll-out and I’m not quite sure the best methodology for making sure all of our customizations survive the upgrade/update.

I started reviewing some of the new screens vs. customized forms. Unsurprisingly, any custom fields I had inserted were blown away. I guess I need to rebuild all of those layers to put them back in.

But, what I wasn’t expecting, is that even some BASE fields were missing from some customization layers… which made them not appear in the resulting form load. Below is one example:

This is the Quote Entry form. I have (3) customized layers.

  • Order Head customizations
  • Order Line customizations
  • and a “Hidden” layer… which just hides unwanted fields that our company doesn’t use.

The missing “Base” fields exist in the “Hidden” customization layer… but don’t exist in the other two.

So, I guess my question is… what is the best approach for correcting this. Should I manually add these Base fields back into my customized layers? Should I wait and see if Epicor fixes this (not sure why Base fields would exist in one of my customized layers, but not the other 2… so I’m not sure if Epicor would consider this a bug or not)?

I could attempt to “Merge” my customized layers… but I’ve never attempted this and I’m unsure how that works. Which layer takes precedence, etc.

Missing the “Sold To” customer information on Quote Entry is pretty important though… so I’mma need to do something.

1 Like

I reported a similar issue in 2022.2 (just at the PRB stage though, not accepted yet). I would report this to support before attempting to fix it. Their promise is that upgrades will be seamless with kinetic. So far, I have had zero problems with our classic customizations upgrading from 2021 to 2022, but numerous (like more than a dozen cases) with our kinetic customizations.

1 Like

Thanks for the response, Alisa.

I’ve entered a case to see if this is something that can be/will be fixed… or if this is something I need to manually repair.

Hello David,

We are facing the same issues as you are. We have numerous custom layers that got messed up after the upgrade to 2023.1. Custom fields are all over the place, standard fields disappeared, layers got corrupt and won’t open anymore, personalisations got corrupt and users can’t open their forms anymore…

Please keep us posted on your findings!

I hope you opened cases too. The more people impacted the more effort that will be put to resolving these issues. Our PRB was finally accepted PRB0264181 for 2022.2.

So far the only response I got from my case was to go into Menu Maintenance and turn off the customized layers and the form should load…

… well, yeah… the form will load. The form DOES load. The standard form isn’t the problem, it is the customized layers that got hacked up.

I haven’t heard anything more on the issue. Hopefully they’ll come back today with something more. But I would guess we’ll have to wait until a future “patch” to get things corrected.

I agree with @aosemwengie1, the more people who have this issue and enter cases the more apt they are to find a solution.

Don’t give up, it took 3 months for me to get from case to accepted PRB for this.

Well, hopefully it doesn’t take THAT long. This update will roll out to the LIVE environments in June, and I’m hoping they can fix it before we all have to deal with complaints from our entire organizations.

We’ve had the exact same issue as you on the Quote Entry screen.

Missing ‘Customer’ and ‘Sold to’/‘Ship to’ fields on the Quote Header tab.
Also missing 90% of the fields on the Quote Line Worksheet tab.

We’d made customisations (layout changes) to these tabs but hadn’t touched the above fields specifically.

When you merge layers you save this as a new layer, so you can test it without affecting your existing layers. I haven’t been able to find information in the online help for how merged layers work. I tend to set the layers in order (e.g. starting with my ‘priority’ layer) and then preview the merged layer to see what it’s decided to do. .

Just received a response from E/C: “This is a known issue at the moment and is under review - as soon as there is an update - will let you know.”

I see this as a good sign because they’re no longer asking me to troubleshoot my database/forms. So, I’m assuming others have chimed in and they’ve realized this a more wide-spread issue.

Cheers to those who entered cases… helps build traction!

… stay tuned.


Okay… update (but not really)… they moved to close my case with no explanation. I rejected their “solution” and stated my issues still persisted and asked if there was a planned solution.

They responded that they have worked on it and the fix had been applied. Then asked me to check on my end and let them know.

The same forms (multiple) are still missing fields… I see no improvements on my end.

Has anybody seen any changes on your 2023.1 Pilot environments? Again, just trying to figure out if its “just me” or if this is still more of a wide-spread issue. Thanks in advance!

Same stuff. Originally PartEntry customization would not load at all. They had a quick fix they applied which resolved at least being able to open the Customization in AppStudio where I was able to repair it. They added additional fields to the base screens, which in turn pushes our custom stuff around.
Working on CustomerEntry customization, and my fields seem to be missing since they added other fields.
My question:
Does anyone know of an “Object Explorer” where we can see if our custom fields and widgets are still on the layer, however, may have been moved elsewhere in the upgrade on the form?

I can re-create them, however, would like to not duplicate things if the fields are lurking elsewhere on the layer.
I tried all the siedebar menus to search, and under Properties to search for my field names and ‘erp-combo’ but no luck.
It would be nice to see some way to search for objects and selecting them from a list takes you to the Card where that item is.
Sounds like a good one to put on Kinetic Ideas, which I will if no one knows of a way to do this now.

It’s a struggle for sure.
Be sure to export your customizations via Solution Workbench so that when Live hits, you have a Solution File that will work quickly.


My PRB on this still shows in progress so as far as I know nothing has been fixed. PRB0264181

I love this idea - as far as I know there is nothing like this in kinetic. If you enter a kinetic idea I’ll vote for it.

Because Kinetic customizations are just JSON, if you are on-premise and have access to the application server, you should be able to go see what the file contains.

What was the quick fix for part entry?

You can do a BAQ also. In 2022.2 it’s a mess. Deleted events never go away.

It is a bug which is fixed in 2023.3, however they only mention Part Entry being affected.


Yes it was. They also applied the .3 patch to ours yesterday due to the other errors so will test that today.

Well, its been a couple weeks now and although my case was converted to a Problem, and was verified to be repeatable, and “accepted”… I have not heard anything back about a planned resolution, etc. I’m assuming they’re working on it.

With Production databases slated to be upgraded on June 9-10… the clock is ticking. I’m still waiting to decide if I need to repair my pages manually, or if they’re going to fix the issues on their end.

Aside from duplicating effort, I’m more concerned with making changes which will then conflict with Epicor’s changes (once pushed out) and I end up in the same place.

I do see they’re planning to push out 2023.1.4 (release notes available), but I have not seen a release date, yet.

An interesting observation this morning, which may or may not have been there previously and perhaps I just didn’t see it.

Some of my missing fields (UD fields) are missing from Quote Entry. I had added a “Quote Revision” field and a “Quote Title” field.

When I go into App Studio, I noticed there was a “warning” that there were “orphaned components”.

If I go to the Details tab (which is where I had them installed) and scroll to the bottom of the page… indeed my two missing fields are there.

What’s odd, however, is this “warning” and “orphaned components” are only visible when I first open App Studio and am looking at the “base layer”.

If I load the customized layer where the fields were actually created… there is NO warning, and the “orphaned components” are not visible. So, here again, if I wanted to put them back into the layer in which they were initially created, I would have to re-create them… even though they exist on the base layer (just moved to the bottom of the form because they were “orphaned”).

In either case… the Epicor Base fields for Sold-To Customer and Bill-To information are still missing. But I was surprised to actually see my missing UD Fields… albeit on the base layer and not my customized layer.