Live on E10.2.200.8; issue with System Monitor


I’ve successfully got E10.2 running live this weekend, and all seems to be functioning correctly. That is except the System Monitor.

I can run tasks and print reports, they show up and complete, even get the ballon popups when they complete. However, I can’t get anything to show up in the system monitor after it prints, it’s just blank. When the task is active it does show up in the Active Task tab, but nothing in the Reports tab or the history tasks.

This did not happen during my testing of…

Any words of wisdom?



if it is in minutes change to Days

@surendrapal, thanks for the quick reply, however it’s already on Minutes…


Nice thought though!

set Minutes and save again in days

Same thing :expressionless:

Opened Retrieval Properties, changed to minutes, clicked ok, opened again, changed to days, clicked ok, and clicked refresh, still nothing…

Did you uninstall the old task agent from the prior version On the server

It’s a completely fresh install; formated server, installed Server 2016, SQL 2016, and E10.2.200.

What is the archive period set to for the things you’re printing?

try with to change archive period Day from 0 Days

Was 0 Days, changed it to Day, but same results.

If I query the ice.SysTask table I can see the records, but not in the System Monitor…

Dumb question but have you tried restarting the task agent service

yupp and rebooted the server too…

The tables that the System Monitor pull from seem to have the correct data in them, so I think it’s a display issue…

Guess I’ll be opening a support call tomorrow morning… Unless @aidacra or @Bart_Elia happen to be around to see this and have any brilliant thoughts? :thinking:

Another dumb question; do you have “display all tasks” shown? If it’s a display issue and you’re running the process as a different user then it wouldn’t show up for your user unless that is marked

Tried that as well…

I think it’s a config issue. Do you have a service account running the task agent?

No it’s the local system account (which is how I had the test server setup as well), should it be a service account?

Yes I believe it’s recommended to use a separate service account for sql, app, and task agent

Well I tried that, but not sure it helped… changed it to the same service account that app pool is using.