Multilple E-mails without anonymous authentication

Is there a way to pass e-mail credentials different than one set up in the company configuration in order to send e-mails with addresses specific to the BPM? It allows you to type whatever you want in the “from” part, but if it isn’t the one set up in the company config with the authentication set up, office 365 won’t send the e-mail. We don’t really want anonymous authentication, but a few context specific from e-mails would be nice.

Short answer… (no)

:disappointed: bummer. Generic "" it is…

You can setup a rules in 365 to allow an account to “send as” someone else… If I recall correctly. So if you setup your account to allow Send on Behalf or Send As then you should be able to change the from dynamically in the email form and it should work… (Don’t quote me on this)

worth a shot.

Typically speaking I would recommend an authenticated SMTP Proxy. This would allow you complete flexibility in sending from Epicor. Option 3 on the link below. It can be a little confusing to get setup but once its working it makes life so much easier.


I want to play with this in my quest to create an E365 for my O365 users:

Microsoft services have been REST-enabled for a bit now. (Worst name ever BTW…)

1 Like

@Banderson ignore what I said @EarlGrei is the grand master of all things IT, do what he says :slight_smile:

Hmm so I went back and re-read the actual documentation they have there and its less complete than I thought. I will try to do a basic write up on this tomorrow morning for the community. I used to work for an MSP and this is what I setup for EVERY company that had an LOB like Epicor for sending emails. I’ve done it so many times that I thought that document was more complete than it is. Sorry about that.

Is there still an option to change the REPLY TO address in emails? if so, isn’t that all you really want?
OR you could give the generic epicor email address delegate authority in you email system?

There is, but I sent some tests, and it didn’t seem to do anything. That was going to be one of my questions.

I saw that article, and maybe that would work too.

edit: I tried setting that up, and it looks like the delegate only works from the outlook client. Trying to auto-send stuff through Epicor doesn’t seem to work.

I can say for certain that what @josecgomez posted about using groups is very easy and works well. While the relay might be the best answer the setup of a group and adding your authenticated user in the Epicor company configuration to the SEND AS permissions works great. We use this on quite a few installs, that have limited infrastructure capabilities,

1 Like

So I tried just the individual user delegate. That must work different then the group then?

Don’t quote me on this but I believe the behavior is a little different. I have setup SEND AS with users but typically that is from the Outlook Web or Outlook so not sure it works the same and I avoid using users for this for cost reasons. Try a group and see if that works for you.

1 Like

Did you ever get around to doing a basic write up for this process? I am interested on how you got Epicor to play nicely with alternate email addresses.

Crap. No I did not. Thank you for brining it up. I will tackle tomorrow.

No worries.

Looking forward to your insight. :slight_smile:

HAHA Oh boy… One Sec. Ill write it up quick. (Busy little beaver here with a project)

Please read this carefully and pay attention to the warning at the bottom. I did this entire thing from memory and its been a while since I have set one up but I am pretty sure I got everything. Let me know if you have any issues and if it works well for you please give credit where its due :wink:

Install IIS 6.0 on a Windows Server in your network. IIRC you also need to enable SMTP Server manually. image image

Once these are installed then (you may have to reboot) you should open IIS 6.0 Admin Console image

This name doesn’t really matter THAT much. Just something descriptive.

Depending on your environment pick the IP you want to use. MOST deployments will just be ‘All Unassigned’

I usually make a directory right in C:\inetpub<DESCNAME>

DO NOT put your actual email domain here. That would cause this SMTP service to try to accept the mail itself. Generally I put my .LOCAL domain in. e10help.local for example.

Right Click and open the Properties for the newly built Email Service.
On the Access Tab Click ‘Connection’ and make sure ‘All Except’ is the chosen option’

Then click ‘Relay’, select ‘Only the list below’ and add the servers that you EXPECT you receive email from. BE 100% SURE YOU ARE SECURING THIS AS ANY EMAIL WILL BE RELAYED.

Next on the ‘Delivery’ Tab click ‘Outbound Security’ make sure that ‘Anonymous access’ is selected and ‘TLS’ is disabled.

Click ‘Outbound Connections’ and set the port to 25.

Then on ‘Advanced’ set a local ID for the FQDN ‘in the case of this server it would be
Then for the smart host you need the MX record that Office 365 gives you.

That is it for the Server side of things. Next we need to setup a receive connector in Office 365. You need your external IP address ( Login to Office 365 as an Exchange Admin. Head into the Exchange Admin for your Tenant. Then ‘Mail Flow’ and ‘Connectors’
Add a new connector. Select From: ‘Your organizations email server’ and To: ‘Office 365’ Click Next

Give it a name. Leave the two check boxes enabled. Click Next

Select the second radio button and add your WAN IP address. (Obviously here is an example because I don’t trust people :wink: ) Click Next

Now Save it.

That’s really it. Now if you point Epicor email sending at port 25 on the server IP locally in your network it should be able to send as ANY address with your domain name as the “” section. FINALLY AND MOST IMPORTANTLY PLEASE PLEASE PLEASE make sure you block anything else in your network from sending out via port 25. You should do this anyway but If you set this up and I knew about it as a user I could masquerade as any person in the internal domain and send whatever I want.