No PO"s being suggested after MRP - but they should

We see suggestions to replenish but no PO’s being suggested. It just stopped working. We can’t explain why it stopped. We ran MRP, we did Regnerative - then we Generated Purchasing Suggestions - no luck. It just stopped for all parts.

@Clambert I would run PO suggestions full regen with logging and look at the log for any clues.

Did you look at the change PO suggestions? Sometimes the suggestions end up there, and no one ever looks at those it seems like.

They show up in Buyer Workbench – but not on TimePhase. Nothing changed in our settings….it just disappeared on my screen. All of them.

MRP seems to be working ok per the logs – but so far no luck as to why they are not visible in TimePhase. And not visible is misleading as it’s not showing.

If you uncheck and recheck the show suggestions checkbox does it make any difference?

No sadly.

Can anyone provide a snapshot of timephase showing a NEW PO suggestion? I need to share with tech support.

Wait what? Support (Epicor support?) is asking you to provide screen shot of what a new PO suggestion looks like?

If that’s the case, you should hit the escalate button. If your ticket is “no PO suggestions” and they are asking to see “PO suggestions” that’s just assenine.

While I can’t disagree with @Banderson it is a holiday week, so here ya go.

no suggestion


Thank you…but i need a PO suggestion for a purchased item that we buy that is not required for a job - but to fulfill a forecast. (if someone can provide an image)

I used to see a suggestion for replenishment for a warehouse - in timephase - and then i would see a PO suggestion before that item - counted back by receiving time, Now that doesn’t happen. But the PO’s are listed in Buyer Workbench - but not showing up in TimePhase. It just stopped 2 days ago.

The PO suggestion in timephase used to have a temporary PO number visible.

I think they wanted an example of what I used to see in TimePhase…but i dont have one.

Usually it’s a date set somewhere. If whoever set up your MRP on a schedule didn’t set the date to dynamic, you probably ran into the cutoff date. Can you post a screen shot of the settings you are using to run MRP?

1 Like

Also can you look at the top of the time phase screen and see if there is a “last run” date, or something like that? I remember something like that happening to us in a past life and that’s when the date thing but us, you could see that the last run date was really old. I’m not near my computer right now to look.

I ran MRP and don’t use a cut off date.

Do you have a test or dev instance that still shows this?

I wish I did….have tried everything I can think of and I can’t even see an image of it online.


Can anyone show a snapshot of time phase with a PO suggestion? One that has a temporary PO # before it gets turned into a valid PO?


I am not aware of anything that makes a temporary PO. We get suggestions and then from the Buyer’s WB those get selected and POs generated.

Ditto @gpayne ‘s comment. Temporary PO numbers aren’t a thing. Change suggestions will list the PO number that should be changed, but that’s it.

Maybe I am mistaken – but PO suggestions were showing in TimePhase and now they are not.