Phantom not pulling materials

I have a phantom in my Config MOM, that isn’t pulling the materials when I “Get details”. As u can see, I have the “SetPartDefualts” in place.

I also have the phantom engineered correctly(I thiink).
Here’s the MOM after I configure.
Can someone plz give me some direction. I’m thinking it’s related to the “Pull/View/Plan as an Assembly” feature.

I think that when the item is an Assembly (or phantom assembly), there might be a different command other than “SetPartDefaults”. I cannot remember, and dont have access to a system right now.
Also, make sure that your new assembly has an approved rev.

1 Like

Hi Anthony,

I struggled with this too. Could it be that you need your rules for QuoteAsm.PartNum instead of what you have, QuoteMtl.PartNum?


Please review your Assembly options on the materials in the BOM. “Plan as assembly” should not be selected.


Vinay Kamboj

Thank you, I’ll try when I get back to the office

QuoteAsm is not an option in my Target entities.

None of the 3 Assembly choices (View, Plan, Pull), are selected.

Hi Anthony,

Can you select it for allow record creation on the Configurator Entry / Detail tab per below? We do not have it on quotes because we just configure at sales order line level, so that uses Job Assembly for the phantoms. I used a case select to make it work regardless of the setup also, like screenshot 2, since we had some phantoms some not. Finally, see screenshots 3,4,5 for our KM001 part setup. The phantom needs to have the same Rev Plant as the parent, I believe, for it to work.

FYI - just in case.

I was able over the weekend to figure out where I made my mistake. I didn’t have any “Material Placeholders” under the optio place holder for the swapped part numbers to fall in. I want to thank all of you for your help.


I’m back with the same/similar problem. I was directed by our Consultant to mark them as “View As Assembly”. It has been working just fine, but this morning, the “SetPart Default” isn’t pulling in the materials. I’ve checked my rules, all looks fine. Can someone plz point me in the right direction?

You need to have phantom parts marked as View as Assembly and pull as assembly

I have other Phantoms, that pull correctly, and none of them have parts in the Phantom marked as any of the choices.

But…I’ll give it a shot.

I marked all of the phantom parts as View & Pull…same result. Parts aren’t pulling. I’m using a replacement BOM, and I have the placeholder marked as View As Assembly. I setup other Phantoms this way, and they’re pulling fine. I’ve gone back to my rules, and all is well there as well. I’m stumped!

Did you find the root cause for this problem? I’m facing a similar issue.

I did not! I still have one Phantom that is pulling as a subassembly. It is identical to all of the other phantoms I use. i have no idea how to correct this.

I’m assuming that you looked a the plant record for the phantom checkbox? The one on the detail screen attempts to change them all, but ultimately, it’s the sites tab one that controls it, because they can be different per site.


I finally found the root cause of this oddness and how to resolve.

First the cause: If the phantom part has the same Revision as your placeholder, it pulls in “correctly”. If on the other hand, it is different, it will not expand into its components. I tried many combinations and could never get a material record to properly expand.

To resolve, I had to specifically have place holders that were marked as pull as assembly. Then in your rules, you set all your assembly variables and use the function, SetCurrentRevision(), instead of the SetPartDefaults() that you would use on a material record.

Hope this helps.

Jim Rogers