Progress Won't Compile Update Code?

--- In vantage@yahoogroups.com, "markewhittaker" <markewhittaker@...>
wrote:
>
> I am new to Vantage, so maybe this is an obvious question. But
others
> at my company are writing programs to update Vantage tables through
> odbc using sql. I was a Progress programmer in a previous job,
> although and older character-based version. I was surprised when I
> wrote a program in the Progress editor and tried to check syntax and
I
> get a message stating that my version of Progress will not compile
> programs which update data in the tables. This happens in version
6.1
> and 8.0. Is this something that Epicor does to protect their data
> integrity and is there a way to get around it?
>
Thanks for pointing me in the right direction. It was a licensing
issue. We had the license for ProVision in 6.1 and were supposed to
get the license for the Open Edge on 8.0, but we never received that
license.
I am new to Vantage, so maybe this is an obvious question. But others
at my company are writing programs to update Vantage tables through
odbc using sql. I was a Progress programmer in a previous job,
although and older character-based version. I was surprised when I
wrote a program in the Progress editor and tried to check syntax and I
get a message stating that my version of Progress will not compile
programs which update data in the tables. This happens in version 6.1
and 8.0. Is this something that Epicor does to protect their data
integrity and is there a way to get around it?
Vantage comes with a read-only Progress License for compiled programs. You need to purchase ProVision for Vantage 6.x and below or OpenEdge Studio for Vantage 8. You might be able to get both for the price of one from Epicor since the 6.x version would be updated to the 8 with normal maintenance.

----- Original Message -----
From: markewhittaker
To: vantage@yahoogroups.com
Sent: Wednesday, June 07, 2006 1:56 PM
Subject: [Vantage] Progress Won't Compile Update Code?


I am new to Vantage, so maybe this is an obvious question. But others
at my company are writing programs to update Vantage tables through
odbc using sql. I was a Progress programmer in a previous job,
although and older character-based version. I was surprised when I
wrote a program in the Progress editor and tried to check syntax and I
get a message stating that my version of Progress will not compile
programs which update data in the tables. This happens in version 6.1
and 8.0. Is this something that Epicor does to protect their data
integrity and is there a way to get around it?





[Non-text portions of this message have been removed]
markewhittaker wrote:
> wrote a program in the Progress editor and tried to check syntax and I
> get a message stating that my version of Progress will not compile
> programs which update data in the tables. This happens in version 6.1

The editor won't generate code to do writes unless you've licensed the
ProVision development package, and installed it with the license codes.

-Wayne Cox
Twenty Three, Inc. -- Information Technology Consulting
828-685-2338