Reports Not Coming Up

The reports are generating, and you can go into the system monitor and see them. From there you can Actions–>Print Preview but it will not automatically cause the pdf to come up without going through all of this. Ideas on why?

Have you doubled-checked if they popup into someone’s else session?

1 Like

Yes. Restarted the computer, still didn’t fix the issue. Kept digging and now they are coming up. Crazy. Like the workstation said, Nope I’m tired right now, then after an hour or so, said, Ok, lets do this. LOL!!! Work snow and I didn’t do anything different.

This does happen once in a while to a few of our users (sometimes even to me) and I either do the magical “Clear Client Cache” or delete the entire Cache folder under ProgramData and it seems to fix the problem.

In his presentation that he gave to our EUG, @aidacra talked about setting up an Alternate Cache Folder location for users in the .sysconfig file (using %username%) in order to prevent issues that need the Clear Client Cache to be performed. I wonder if following this recommended best practice (especially if you are “an RDS/Citrix server/RemoteApp type client deployment”) would help with this problem?

I also wonder if it would help us when we modify an Updateable Dashboard and some of our users don’t see the newest version.

I’m going to give this recommendation a try and see if it helps with these issues that we face.

Glad you got it working again but I hate mysteries like that cause you know they will rear their ugly heads again… :smiling_imp:


When that happens, I have my users clear the cache, then restart Epicor.
They usually pop up after that.