$ sign on Check in Accounts Payable check generation

Hi - wanted to see if anyone had a similar issue. When generating checks in Accounts Payable, the “$” sign is showing at the end of the dollar amount instead of the front.

I just wanted to remove the $ sign completely by updating the “currency symbol” field from “$” to Null/blank in the Currency Master Maintenance menu. However, it won’t let me leave that field blank or null. It requires me to put something in there. I put a period (.) in and now a period shows at the end of the check amount:)

Any ideas how to fix this without development? we are new to epicore
Thanks Pete

Have you tried a single space? If that’s no go, try a non-breaking space Char(160).

Thanks Calvin - tried option #1 and system didn’t like it. Can you tell me how to type a non-breaking space Char(160)?

Alt+0160 on a windows machine (it might have to actually be the number pad keys)


Hold down the ALT key for the entire 4 numbers. You should see the cursom move a “space” over after the last 0 is hit (might take a second)

Thanks Calvin - Those steps definately worked as it added the blank space, however upon saving it still gave me the error “currency symbol is required”. Appreciate the help though

Hmmm… mine is blank.


Do you have more than one currency setup?

Just one currency for us - strange that yours is empty. My page looks exactly like yours but won’t let me clear out that $ from the currency symbol field.

I’m on 10.2.300. Upgraded from 10.1.400 (which was a virgin install). So that was probably never set. I wonder if once it’s been set, it can’t be cleared.

Whoops …

I entered $ into the Symbol field and saved. Then I deleted it and now get:


But no big deal as this was in my test environment.

whoops! Glad it was just your test environment. Thanks again for trying

The error appears to happen during the BO Currency.OnChangeDecimals Which is odd that is even being called as the decimals haven’t changed.

Currency Symbol is always required, always has been. But Epicor seems to have a bug when you create a new Company it will create it with Blank.

Maybe do it in the SSRS report RDL?

I had a similar request in V8 were we used a calculated field in the Crystal Report to replace the $ sign with “Dollars” and remove trailing asterisks.
e.g. “****** " & Replace(Replace({checkhed.Calc_DspWordAmt},”*",""),“Dollars”,"")

define “required” …


So code check for it when changing the Currency record, but not when creating it?

Sounds like a bug to me.

And since it is currently Blank in our Production DB, should I be worried about referential integrity?

Yes prob a bug, cought us many times.

But a bug without consequences? I mean having it not set only prevents you from changing something on the Currency record, right? Or are there other consequences?

I really haven’t found any consequences yet, unless I am trying to make a script to update our Exchange Rates and providing the proper currency Symbol.

We ran with Blank for years just fine. It seems like its just used on Reports. But also seems Epicors intent was to make it mandatory, but they just have it in the wrong place.

So if you accidently have set it, you can prob unset it via Updatable BAQ.

It wouldn’t work with the Business Object from Erp.Currency. Had to change the Business Object from Erp.Currency to Erp.Company

Query returned 1 row(s).
Updatable query action fulfilled and reported no error.

And it worked (cleared the Currency Symbol field).

@littlesistersba - Here’s a uBAQ to change it.

E10H-CurrencySym.baq (21.0 KB)
(my version is 10.2.300.23)