Simple Updatable Query Text: Update of Order Release not allowed

We Just got done updating from 10.1.200 to 10.2.500. I had this dashboard working with an updatable query to update a UD field in the OrderRel table.

The query was working before the update.

Thinking there was something that needed to be “refreshed” I opened the query and check the settings all looked good and like I said the query was allowing updates before the upgrade to 10.2.500. Just to test
I created a simple update query to see if the original query where the BacklogDate_c is updatable.

Am I doing something that needs to change in 10.2.500?

Is the Release you’re testing on Open?

Looks like it’s an issue with that BO/Method OrderRelSearch.UpdateExt. Try using SalesOrder.UpdateExt instead (I was able to update a closed release with it).

1 Like

Release is open

when i tried using SalesOrder I got this error when i tried to save the query

You either need to include those key fields from those tables (OrderHed/OrderDtl) in your results set OR change the expression on that “Query to Object Column Mapping” table to match a field in your results table.

Option 1 (just add extra fields to results)

Option 2 (change expression on query to object column mapping to reference a field that is actually in your result set)

The expressions here (all the ttResults) need to relate to one of the fields in your results. So if you dont include OrderHed.OrderNum , you would need to change the expression to ttResult.OrderRel_OrderNum to point it to the right place. These are the “non-existent results columns”.

1 Like

Ok i tried it both ways and it worked with SalesOrder. I wonder what happened from 10.1.200 to make this happen?


Good deal. I guess they changed how the other method works. Kinda makes more sense to me that you can’t update using a search object.