SSRS formatting/row height


SSRS issues of the day…

I’m afraid I already know the answer, but is it possible to tighten up the spacing between rows? No matter what I do with row height or cell padding, it doesn’t seem to matter, this is as tight as the rows will go. I’d like to remove white space where the red lines are as I’m working with a small label and I’m running out of real estate.

Also, I can’t seem to find a way to bold the word supplier in this expression:
="Supplier: " & Fields!VendName.Value

I’ve found things online mentioning place holder work arounds, but I can’t get that to work.

Thank you.

For the bold, set it using HTML.

="<b>Supplier:</b> " & Fields!VendName.Value

Then edit the textbox properties and render it as HTML.

1 Like

Can you share a screenshot of the row groupings in your designer? This will help us understand what might be causing some additional space.

As for the bolding, you should be able to highlight the expression on the design surface and right click > placholder properties.

Click the radio button to allow HTML tag interpretation.

You can then include tags apart of your expressions and it will be bolded. <b></b>


Thanks, Aaron…I had tried that, but not with the ‘render as HTML’, which I’m not seeing anywhere.

Thanks, Chance, that was the missing link!

Ok, for the row height, no groupings at this point, just details.

Right on. Sort of tucked away setting that requires weird highlighting to see.

For the spacing, sounds like you have checked Row Padding/Cell Padding which is good. Make sure your padding is all zeros

I would recommend shrinking your rows beyond what they visibly look like they can handle, and make sure the CanGrow property is set to true. This will let SSRS determine the bare minimum space required.

Make sure you have no borders set

Beyond that I’m not sure how much tighter you could make it without hacking a overlapping solution.

1 Like

Thank you…yeah I’ve messed with those values and it seems this is as much control as SSRS allows.

I try not to get too upset with being forced to use this subpar software, but it’s 2021 and I can’t move a row of text exactly where I want it…


Only limitations I have ran into are repeating column headers and showing totals at the bottom of reports (without consuming page footer space). Its frustrating for awhile for sure, but once you understand its quirks its tolerable and gets the job done.

If you are looking for granular control of field placement, try putting a rectangle inside of your cell. Then add a text box. This will allow you to control where you want your field inside the cell pixel by pixel. This is how Epicor designs their base forms when things don’t need to export cleanly to excel.

1 Like

Multiple rectangles inside of a cell, along with the padding change, has me close enough to move on to the next one.

Thanks again, Chance, you’re a gentleman and a scholar!

1 Like

Care to share a screenshot for others that come along looking for how you got the desired result? Want to see the difference in the design view.

I can do that…

I was trying to stick with 1:1 row/field as I don’t like the tedious nature of fighting their text boxes and rectangles, but as we saw, that wasn’t working. So where I need tight spacing, I’ll have to add multiple fields per row, remove the padding from each field and basically overlap them in designer…even this doesn’t get them as close as desired(red box), but my options are few and it’s better than the spacing between rows (green box).