UD Field Assistance - Post E9->E10 Migration

In Epicor 9 on the User Account Maintenance Screen we added a new Textbox Field, and set the EpiBinding for it to User.Character01 … it works as expected…we populate that field with something, save the user, look in the DB, and User.Character01 for that specific user is populated.

After we migrated to E10, I went to the customization for this form and I receive an error that says:

  • Control ‘txtEpiCustom1’ of type EpiTextBox has an invalid binding to User.Character01.


When I go to the EpiBinding property of that field in E10, it does not show the User.Character01 field as an option. So, I took this opportunity to poke around the Epicor SQL DB.

Looking at the Erp.UserFile table, I see there are no fields for Character*, Date*, etc. It seems that they were moved into Erp.UserFile_UD. In there, I have my Character01, along with the ForeignSysRowID and UD_SysRevID columns.

I also notice that there is a View named dbo.UserFile. That view contains the contents of Erp.UserFile that has been LEFT OUTER JOIN’d to Erp.UserFile_UD, therefore containing that Character01 field.

So, I started doing some reading and came across some posts about the Extended User Defined Table Maintenance menu. In there, I saw that UserFile_UD was already in there with Character01 listed as one of the columns…so, I assume that was done during the migration process.

After finding all of that information, I am still no closer to where I need to be. I can’t seem to figure out what I need to do to be able to get that UD to be used as an EpiBinding to a textbox. Can anyone point me in the right direction? I have been playing with this for about 5 hours now when absolutely no progress being made.

Epicor Version: 10.1.600.15

If you extend Ice.SysUserFile and add your column, you should be able to then see it in the customization. You will need to move your data also.

That sounds easy enough, heh. I assume there is a proper way to go about that and I shouldn’t just open up Ice.SysUserFile and add a new column to it.

Just use extended table maintenance and select the table and then add your column. You will need to regenerate your data model.

That field "should " be in the User table when working in the customization screen. Epicor takes care of all of the connections in the background now and makes whatever field you create look like it is actually part of the system table when it is really in _UD table.

You can actually create the fields to have relevant column names too instead of the generic ones from the older versions.

Hi Jason,

I agree with John that the field “should” be in the user table and carried into customization automagically like it did for my PO entry customization screenshots below:


Nancy, John, Dan,

This is what I have in UD Table Maintenance:

I assume that I am supposed to input some value(s) into the fields that are marked with the red box…My guess would be the values should be: Erp UserFile_UD Character01 …but I am not too sure.

Hi Jason,

I did not have to complete any “like” field to make it available to the customization. See below. I suspect the “erp” type vs “ice” type may be causing problem with not having your field available in customization.


I looked at the Erp.UserFile_UD in the UD Table Maintenance, and it has Character01 in there. Here are the screens for it:

That was in there automatically from the conversion (which is to be expected, I would think). That is why I am so confused as to why it is an available selection for the EpiBinding on that control in the customization. I can’t seem to figure out of I missed a step somewhere with having to ‘approve’ that UD during my post-migration tasks, or if it is something bigger and I am going to have to reach out to Epicor’s tech support.

I am pretty sure UD creation in Erp.SysUserFile is a bug. If you create the Ice.SysUSerFile_UD it works just fine


I can create a new UD field and have that appear without any issue (it would have the _c at the end of the field name)…however, the Character01 UD field from E9 is already populated and that is what I need to reference.

So it is not showing up, interesting.

I think the quickest fix is to create a new column and copy the Character1 values into the new one you just created. Not the best, but probably the easiest.

That was my thought as well. I just find it irritating to have to do so simply because Epicor made an effort to be sure we wouldn’t have to do that, heh.

1 Like

I agree @jhecker that this should not happen, but I suspect several people discover this issue and just use SQL to move the data and perhaps never bother telling support about the problem. Might be good to have @aidacra take a peek and let us know if perhaps there is an SCR or data fix that exists to address this problem. If not, it might be a good idea to create a support ticket to help users that may be converting in the future.

1 Like

I have opened a ticket with Epicor Tech Support. Let’s see if they are able to provide a any insight as to something that I may have missed, or if they tell me to create a new UD, and copy the data from one to the other.

This still happens in 10.1.500.31 – I Migrated over about 100+ Fields that I had in E9 and I can’t modify the FieldScale, Format, Description etc…

Also there is no Method Directive for:

Program: Ice.Services.BO.ZDataTable.dll
Method: ValidateUserDefinedColumn

I was hoping to override the Base.

Maybe @Bart_Elia can expose the ValidateUserDefinedColumn Method in Method Directives in the future and we can override it. It doesn’t make sense for me to recreate 431 UD Columns with a _c which already are used in Customizations, Reports, Labels, RDDs…

I am confused. These were made in E9 and not migrated?

They were made in E9 and they migrated to E10… which is good - but I can’t change anything anymore on them… in 400 i could change the FieldFormat…

I want to continue to use my legacy UD Columns that all 300+ from E9 regardless of _c =)

1 Like

Yea looks like a bug - Ticket Please.
As a workaround, have you tried locking down the custom fields attributes in Extended Properties Maintenance?

1 Like

@hkeric.wci Update - It was already fixed: SCR 201972 in 10.2

1 Like