UOM class conversion

Hello!

First post here, but it’s been an amazing resource on our journey to E10 Cloud; we’re now live!

We are having an age old problem: an engineer created a part with the wrong UOM class (COUNTED UNITS instead of LENGTH). The unit is stored and used in inches, as opposed to each, so there is no natural conversion for this.

I am aware of the UOM Conversion Maintenance Utility, but do not understand its requirements. It allows me to select a different class than the current class, but according to the application help, both classes must have the same conversions. Does this mean that our COUNTED UNITS class must have a conversion of 1 EA = 1 IN? Can this be added temporarily and then removed?

We have removed all demand for this part, but are receiving a “Missing conversion to UOM code DOZ”. This seems to confirm what I’m reading in the application help.

Any suggestions would be appreciated!

Thanks

You need to make a temporary class of type OTHER, that has all the UOMs of COUNT and of class LENGTH in it. Make the default UOM for inches with a conversions of 1 EA = 1 IN (assuming that’s how the wrong class has been used)

Then convert the part’s UOM class to your temp class. And change the IUM to IN.

Now remove all the COUNT based UOMs from your temp class. It should only have UOMs for LENGTH. Finally, do a conversion from your temp class to the LENGTH class.

But be warned, there are many situations that will prevent this from working. You may be better off making a new part number with the correct UOM class.

2 Likes

Thanks for the prompt help. In this case, the part is listed as a material on an open job and the converter is throwing an error about this. Will closing the job get us past this? Or will that JobMtl record stay around to haunt us forever?

Honestly … It depends…

I’ve tried to do some conversions (we to have had people create P/N’s for pipe or wire and use COUNT and EA), and after doing everything it required (no open demand, po’s orders, materials, QOH, etc…) it still balked because there were existing parttran records. But then I’ve had other go through even with pre-existing parttran records.

:man_shrugging:

Welp, I was able to convert to my “TEMP” class, but unable to move to next final step due to the issues mentioned in this thread (that I see you were also involved in). I cannot remove unnecessary UOMs from the temp class due to the “Not allowed to delete UOM Conversion, only to mark it as Inactive.” error.

1 Like

@fvodden You have to unset the has been used flag on the uom conversion to be able to delete it. If there are not parttran records in that uom you should be able to do this in a ubaq. I also saw a recent thread where they set the track on hand in the new uom and then were able to uncheck the track in the old uom.

We have a new part review dashboard to review all new parts to catch as many of these issue as soon as possible because as soon as you have parttran records it becomes a way more complex task.

We’re on 10.2.700.10. My knowledge of updatable BAQs is admittedly limited, but after the UOMConv_HasBeenUsed column to my BAQ, the Updatable checkbox is greyed out on the Update → General Properties tab. Read only is also checked. Other fields (code, class, etc) are available for update. It does not appear that I am allowed to manipulate that field.

I opened a ticket with support and received two answered. First was “In regards to Not allowed to delete UOM Conversion, only mark it as inactive, that is correct, by design you are not allowed to delete them.”. Secondly, they stated that the inability to mark conversions inactive is a known issue that is being worked.

If that bug is fixed, is marking the UOM inactive good enough for the Part UOM Converter tool?

Thanks for your help. We’ll likely just create a new part.

@fvodden Probably this would need a custom update. the biggest thing with UOMs and Part configurations is that they have to be review soon after being made or they are set.

On the will inactive be excluded from the UOM validation in the UOM conversion tool. I would reach back out to support to ask them add that question to the PR for the bug.