User logs in and immediately out

I have a user that when he logs into Epicor it opens then immediately closes. We’ve occasionally got it to work by deleting personalizations or repeated reboots. Today, it happened again and he has no personalizations currently and is in the process of rebooting. Any ideas? (It doesn’t help that it’s the CEO of the company who is the one having issues…)

If it helps, it’s based on user not computer. I can log into his computer and it is fine. He cannot login to mine.

In user maintenance try removing his companies and adding them back. There is a KB depending on the message.

Setting compatibility on the shortcut sometimes will also cure this.

Tried removing and adding, no change.
There is no message and if you check the User Account Maintenance, it shows a valid login.

Ran compatibility checker. Recommended running as Vista Service Pack 3. Same result.

Also, does the same thing if opened in Classic mode. Opens the screen then closes 1 second later.

Had similar issue at a past client. Ended up we had to delete the user and re-add them.

Open SysMonitor (while logged in as a sec manager) and check if there’s any tasks queued for that user. Maybe try disabling the sys monitor startup on login - I think that’s a setting in user maintenance

Pardon my general network admin ignorance, but is this Windows Vista?!

Is that supported with Epicor?

I’m pretty sure that was the compatibility mode they wanted him to try.

For one of the times you get it to work, can you look in settings, preferences, then check in the tabs tab? There is some intended use case to automatically open screens when the user launches Epicor, but it never really works right, and can cause problems like you are seeing.

I’m not 100% sure that this is it, but it could be.

1 Like

That’s what the recommended was. We aren’t using Vista. Although there are times it might be an improvement…

So the issue has started again today. It had stopped but restarted. I checked the tabs thing @Banderson had recommended, but unfortunately that is not it.

Trying a quick bandaid so my boss can pull the info he needs before his meeting. I create a new user ID with all the same permissions and link it to his employee. He logs in, it immediately logs him back out. Same behavior, new User ID. I can log into Epicor with my user ID on his computer and it is fine. (Let him use my username to go ahead and get the info he needed for his meeting) . Try his user name and his new user on my computer, does not work. Log back in with my user, change his user to point at a different employee (should make no difference, but the brand new user should have worked as well). Still same behavior. Opens, then closes within seconds.

Seems the moment a user is pointed at his employee, it gains this behavior of sometimes working, sometimes not. Pointing it at a different employee does not fix it. Any thoughts, recommendations, or ideas?

Can log in as my user, then switch to his user and that’s fine. Doesn’t force log out like it does when logging directly in with this user.

Hi Todd,

Just putting this out there in case… we had a problem once with it and it did cause user inability to login because it couldn’t handle all opening up at once. Could it be this?


For those that come after, why this makes the difference I don’t know. Why it only causes issues every few weeks, I don’t know. But turning this off fixes the issue:

Under User Account Maintenance, Tracing tab:

Turning this off fixes the issue.


That’s a good catch. I did not think of that! Log files can get too large and or have something in in that corrupts your session. Really, you should only have logging on of you are actively trying to fix a problem. Glad you figured it out!

1 Like

Tracing should only be on when you are actively debugging a problem. Most of us would have assumed it was off.

He’ll likely see a good speedup as well, depending on what the trace settings were.

I’m honestly not sure why it was even turned on for him as he wouldn’t know what to look at it in it. My guess is when he was set up, the person doing setup didn’t know what they were doing and since he’s the CEO, they just checked everything. There are a few other permissions that we’ve taken away simply because he has no reason for them.