XL Connect error: Unable to create specified ActiveX control (after Microsoft updates)

After a recent Microsoft Office Update (including one for Excel, and a .NET update) was just auto-installed by Windows Update on the server, Epicor XL Connect now returns the error “BizInsight has fired an exception”… Exception Message: Unable to create specified ActiveX control.

Suggestions on how to get XL Connect working again?

We fought this for 2 weeks. The most recent .NET framework broke this. Uninstall your .NET framework and revert to the last one.

1 Like

Thanks for that feedback, Tyler! And only the .NET Framework update caused the issue? You did not need to uninstall the Excel and MS Office updates too, (in your experience)?

Did you also have to re-install the previous .NET framework version in order to revert?

Any reboots required (if you recall)?

I setup XL Connect for my company and tried several solutions to resolve this and after many un-installation attempts and configurations. We finally went back one version and restarted the PC and it worked. (Don’t forget about your host server for XL Connect)

Curious here, but what version of XL Connect and .NET framework?

This was right on! Uninstalled the last .NET Framework security update, and it solved the problem.

Did you uninstall from the Client only, or from the Client AND the Server to get it to work?

Just the client.

CONFIDENTIALITY NOTICE: This e-mail and the transmitted documents contain private, privileged and confidential information belonging to the sender. The information therein is solely for the use of the addressee. If your receipt of this transmission has occurred as the result of an error, please immediately notify us so we can arrange for the return of the documents. In such circumstances, you are advised that you may not disclose, copy, distribute or take any other action in reliance on the information transmitted.

Try Removing the below Windows updates also , if the .net update removal does not work.