Zebra QLN 420 not printing

We have a really odd issue at hand. It looks like things are supposed to be working but nothing is printing.

We are doing an Epicor > Commander > Bartender setup and auto-printing to a Zebra QLN 420 printer.

In commander the command scripts looked good, going to the right bartender label, printing to a right printer and it is generating a good output file.

We are using Seagull’s Zebra Qln 420 CPCL driver for the printer.

The portable printer is set up in the same server as our Appserver (epic-appp) and is shared.

Bartender and Commander are located in a separate server (epic-aps).

The labels prints correctly if we click “Print” directly from Bartender, and any job we send directly to it will print as well.

It just would not print from Commander for some reasons.

I’m assuming it’s using a drop file and a watch folder correct? If you manually create the .csv (or .bt or whatever it wants to call it) does the commander pick it up and run the file?

I’m not 100% sure on Epicors use of bartender so correct my if I’m wrong (I write my own csv’s in code and drop them into folders) but usually the commander is looking for a trigger file to be dropped somewhere, so it wouldn’t be using a server printer set-up right?

Again, I don’t use the bartender out of the system like Epicor intended, so I could be off on my assumptions.

From the help files.

You then add the Auto Print action element to the directive workflow, configuring the BPM to generate a .bt (BarTender) file in a folder on the server.

So yeah, this. If you manually create the .bt file does it work?

I tried modifying one of the files manually and dropping it as a .bt, it would be picked up by Bartender and it would be processed, then changed to a .btw, but no print :frowning:

Our workflow is as such:

  1. Whenever an issue material occurs, trigger an AutoPrint BPM. This is where we set up which printer to use.
  2. It will then create a .bt file to a folder where Commander is watching. it will then process it from Bartender and print it.

ok. so the drop file part is working then. It’s a bartender issue at this stage. (I’m assuming you are using the stock formats.)

You should be able to go to your server that bartender is on and see some messages on the processes (assuming that you are on the newer versions of bartender). Can you look there and see if that gives you some clues?

1 Like

Interesting…I do not have that console…

You might have an older version. It’s not called commander anymore. But I still believe it’s a problem with the file setup not recognizing the file the right way. It’s probably something minor. Also, bad characters can cause problems with bartender so try with some different data, or check the file in notepad++ and look with all characters on and see if you see anything goofy.

First of all your Printer Network Path should look probably like a Network Path


Also when you Print from Epicor, you have to have a Workstation assigned that has that Device (Printer) attached to it.

You can also paste your Epicor Generated .txt/.csv/.btp file, it should show you missing params.

1 Like

Right. I did try that and it still did not work. In my autoprint i also have it set up to go to each person’s default printer in their workstation.

In your screen shot at the beginning, there is no data in that file under the header. Did you just leave it off?

edit maybe that’s not the drop file. Can we see the contents of that?

Go to Commander and Somewhere in the File Menu Bar there is a Service Settings… Button. Stop BarTender and change it from “Service” to the other option, I cant remember “Run As Application” or something… Then you will get to see the BarTender window (it wont be hidden). When you fire it up, if BarTender throws any warnings or errors you will see them then…

In addition to the printer… Your .btw file is epic-app while the .BTP file you want bartender to read is epic-apppp. I still believe you have to fix your Printer :slight_smile: You have to Share the Printer.

When I run the as application and click OK it just freezes Commander…

Yeah,that was an interesting setup that happened before I got here. the labels was actually saved in epic-app, epicor in epic-appp, and bartender in epic-aps.

What if you go to Tools -> History something, I think History Explorer, that one shows errors too.

Generic Inventory1375244.txt (5.1 KB)

Here is a .bt file that I re-saved as a txt so that I can upload it here.

On your Computer if you go to Start -> Run and type in


The IssueMtlTag.btw exists?


If you go to Start -> Run and type in:


The printer gets installed/downloaded, you don’t get an error not being able to access that Printer?

Yes sir.

File explorer got stuck here. Let’s see what’s going on…

False alarm, i restarted print spooler and it now works fine…

Now go to your Commander Server and put \\epic-appp\HandHeldPrinter01 into Run make sure it can access it. Change your Epicor Printer setting Network Path to \\epic-appp\HandHeldPrinter01

Then you should be good, given that your BT stops freezing on the Server :slight_smile:

1 Like

That’s what I currently have and no dice. Im gonna leave the printer on and see what happens tomorrow :cry:

You have to run it in Application Mode, see what the error is… Sometimes its as simple as Windows is blocking it with a “Do you trust this Printer Dialog box” which you wont see in Service Mode.

If you Print, Epicor will generate a new .csv - if all variables are good, it should pick it up and you should even see it in the Commander Log Window.