Adding Materials to a Job - tries to change previously added material

I have a really weird error happening…

When a user tries to add a material to a Job, as soon as they tab out of the part number field it will change the part number of the previously added material. (previous mtl seq)

If the previous material has a PO or has been Issued it will throw an exception saying that the part can’t be changed because it has PO or Issued

This only seems to be happening if it is an added material (a day or so after the job was initially set up)

Its as if the Job Material table is one line out of sync… is that even possible

Perhaps if a material was removed from the job, then added again. I have seen instances (just can’t remember that they sequence numbering goes out of wack if lines are deleted. It might even be order releases).

Are you sure there are no customisations on that form or bpms on the validation method, that might exist for the job. Perhaps there’s a Pre-JobUpdate or similarly.

If it’s only happening for one user, then I’d be starting with a clear client cache.

Missed the testing bit… Definitely check for BPMs and code.

It’s happening to multi users, the jobs havn’t had mtl’s deleted…

Done the standard CCC and restarts…

I’ve just re-visited any BPM’s related to Job Entry and opened them to see if I could see any problems, I didn’t make any changes but when I tried the process again it worked without error

I’ll monitor to see if it keeps happening

1 Like

Glad to hear it.

Arrghhh, it’s still happening!!!

Has anyone got any ideas??

You could turn tracing on with all the Server options checked. Something may turn up there.

You may find Jose’s wonderful trace helper utility helpful in analyzing the trace logs.


Any chance you could do a short video capture of the behaviour. The other thing to ask, are there any default dialogs disabled? (You know in the Tools/Options menu item)

Fingers crossed… I’ve just regen’ed the DB, it seems to have solved it for now

Just sent you an email sorry.