Allow Access to All Groups/Users

Hello, new to the forums but wanted to check if anyone else has seen this before I create a ticket with Epicor.

“Allow Access to All Groups/Users” is checked and grayed out on Menu Maintenance. I suspect this is causing users to have visibility to certain modules we want to restrict access from. Example, I created a new user and didn’t assign any groups, yet they can still see things such as Order Entry etc…

Does anyone know how to uncheck this? Is there any ramifications if I did find a way?


Thank you,

What menu item is this screen shot from? If you let us know we can compare to our environments to see if it is the same for us.

Its actually on every menu item, even the Main Menu. Which seems a bit odd to me.


Well that’s the main menu point. If a user doesn’t have access to that, then they can’t access anything.

That’s a valid point, but all menu items have this setting enabled.

Can you add users to the “Disallow Access”?

Maybe 10.2.700 defaults to “Allow Access …” until you specifically set some to be disallowed.

In 10.2.300 defaults to “Allow Access …” being checked (and enabled), and with all the users in Groups/Users.

Unchecking that box then allows me to select specific users to move to the “Selected Groups/Users” list.

Perhaps there is field security set on your user? Are you THE global sec manager?

I thought the same thing about the Menu Item needing at least one group or user moved into the container before it’s allowed to disable that setting but even the move users is grayed out for me. No I’m using my profile (I’m a security manager).

I’ve created a ticket with Epicor to see if there is a setting somewhere that I’m overlooking that enables this option.

I wonder what would happen if you tried changing it via DMT

If you do try it, make sure to include users in the AllowAccess list

In your profile it says you are MT. That might be why. Can any other MT users confirm?

In Cloud environment you need to copy the security so that ‘Owning Company’ is populated with your Site. So with the SecurityID open go to Actions > Copy Security to Current Company. Now you will have a company specific security which you can modify.

1 Like

I may have found the issue, I was able to select the Reports sub-container and this option is no longer greyed out for me. It’s as if I have to make these changes at the child menu items rather than the parent.

In your example, the securityID UD13 is a custom SecurityID (not baseline). Therefore when created it populated the ‘Owning Company’ with your site and you can modify. So for baseline SecurityID’s you can select the SecurityID and then Actions > Copy Security to Current Company.


Thanks everyone for the input! I should be able to get it sorted out now.