AR Form custom report RDD and style failing

I have a ticket open with epicor, but after two calls I am no closer to a solution.
We have a custom RDD that’s built off of the ARForm RDD. It adds in tables drop ship dtl, rma dtl, and ship dtl. A custom report style is built on this custom RDD and it worked perfectly in 10.1.500.11 and in a 10.2.100 version.
When we moved to, it now fails to run with the infamous “too many columns” error.
I’ve tried excluding literally hundreds of columns and labels to no avail.
I also tried a test wherein I copied the base ARForm RDD and only added one table. Then, I created a new report style that uses the base Epicor AR form. It then still fails for the same reason.

I’m hoping someone else has experienced this fun problem, and if so is able to help. Thanks

In the past excluding columns has been the solution for my environment. Perhaps you should look into excluding tables and consider using existing links if possible. An alternate option is to use sub-reports.


Hi mazin, normally I would completely agree with you, but this time feels different. As I stated, I tried removing many non-needed columns with no affect. Interestingly, it seemed removing certain columns caused the report to fail at different report label locations, so clearly there is some sort of internal query it is running to return the native dataset. Additionally, I find this confusing because in my test where I copied the native RDD and added a single table, then ran a copy of the native RDL against that new RDD, it still fails due to too many columns, even though I did not include any columns from the new single table.

Hi Aaron,

You mentioned that you already tried a test where you copied the base ARForm RDD and only added one table. Then, you created a new report style that uses the base Epicor AR form with the added table. What happens when you don’t add an additional table with a corresponding relationship? Also for the added table what is the Relation Type?

Moreover, under the Linked Tables tab are there any available Pick Links to pick from?

I am having the same issue with our custom SSRS report RDD. I have excluded pretty much everything I can of column labels yet I am not able to get the report to run. I think I get passed the error that I have exeeded 1024 column labels for RptLabels then I have to add a couple of calculated fields that got missed during the upgrade from 10.1.600.8, just so I can go back to the error: CREATE View failed because column X in view RptLables exceeded the maximum 1024 columns.

I spent 3 hrs trying to fix the RDD yesterday and are going to give it another try again this morning. My RDD came from 10.1.600.8.

Do you want to give me your ticket number so I can add it to my ticket if I can’t get my RDD to work. I hope the answer isn’t that we have to start all the way over from a new base RDD. And do we have to then to that for every release upgrade? That will take additional time to test each go around.

Ticket number CS0000940012. I am running out of ideas, short of re-creating everything.
I also see that they added much to the dataset query, so I tried fitting my original query into that one while renaming the table variables, but no luck

I’ll let you know if I can get mine to work or not and I will give you my ticket number when I create one. It may help that we are multiple companies reporting the same issue.

So I ran into the same issue with our AR Form when we went from 10.1 to 10.2
Unfortunately the only resolution really is to go through and remove the columns.
The error in the system monitor should hopefully tell you the table you’re getting the error on.
In our case it was the actual columns labels themselves that were causing errors not the columns.

I was fortunate that I was able to strip out what we weren’t using and still have it function without rebuilding.

edit: I also went through support, for the exact same issue and never got anywhere. It was actually less frustrating to modify the report.

@edejonge - when you say strip out (remove) the columns are you meaning excluding from the dataset? Mine are also the report labels exceeding the column limit of 1024 columns.

I’ve been having issues with 1024 columns exceed for the past 3 updates. The only solution I found was to copy the BASE RDD and make a new one, Add the table you want (one at a time), Run the standard report based off the RDD you’ve copied, IF (1024 COLUMN) ERROR, then exclude columns and labels and run standard report again, IF NO (1024 COLUMN) ERROR then continue onto the next table you want to add. Repeat until all tables have been added and there are no errors when you run the standard report. After that you’ll attach the new RDD to your custom report style and check to see if it works.

@kfierce Yeah, sorry for not being clearer. They added a few tables and there is a lot that isn’t being used in our report. I ended up removing the labels for all the new tables.
There were a few that I had to go back and add back in. Fortunately the error that came back told me specifically which column the report was looking for and failing on.

We got it to work after recreating the RDD from scratch. Once this was done, we were able to use the custom RDL with it and the report was restored. It was really unfortunate that we needed to do this though because certain fields that had been defined in the old standard RDD were no longer defined in the new one. For example, the rptliterals ref invoice num field of the invoice dtl data seems to pull no data while the invoice reference number exists. I’ll post some screenshots tomorrow if that helps to explain it

Good to hear it’s working. Its a pain when the base RDD gets updated with new fields / tables / labels and what not. From my experience, i have to recreate the custom RDD based off of the new base RDD all the time if the base RDD keeps getting things added to it.

1 Like

We’re in the same boat… Just started testing 10.2.100, and getting similar errors.

Is there any point to submitting an EpicCare ticket? I’d expect the up-conversion from 10.0 or 10.1 to 10.2 to go smoother…

Honestly, not really. Support was quite hostile and unhelpful with this. I had to recreate the RDD from scratch and was able to fit it mostly into the custom RDL that we had been using.
Epicor’s solution was to a) re-create the RDD and b) re-create the RDL which was disappointing.
I was lucky that my RDL worked with minor tweaks


Did most of the custom report migrate over fine, and these are the exception? Or will we need to recreate the RDD’s on the majority of our custom reports?

Any ideas on how we could avoid a similar issue when 10.3 comes out?

The AR invoice was the exception in my case, and I haven’t seen any other issues with the reports. It happens to be that AR invoice is incredible complex, so I’m with you on the frustration in potentially needing to recreate. Most likely, you will be able tweak the ARForm query after recreating the RDD (to bring in your new fields) and be able to use the custom RDL.
No idea how to avoid. It sure makes upgrading a dangerous decision if custom RDDs are not supported.

We found it easier to recreate custom RDDs going from 10.0 to 10.2. ARFORM seemed to be the biggest issue for us IIRC.

Mark W.

1 Like

AR Invoice Form was the only RDD I had to recreate from scratch when upgrading from 10.1.600.8. All other custom RDDs didn’t need any uplift. We updated to 10.200.3.

1 Like

99% of the time, the Too Many Columns error is a result of the Label Table exceeding the standard SQL table max of 1024 columns and you really only need to exclude the Labels for new tables added. The RDD UI has Actions menu options for Exclude/Include All Labels and Exclude/Include Selected Labels so you do not need to check each one.

Epicor will address this issue with the 10.2.300 release with the use of the SQL Wide Table option and potentially smarter inclusion of Report Labels.