AR Reconciliation Stuck in Active Tasks

I have a ticket in, but haven’t herd back yet and I need this fixed today, if possible. AR Reconciliation is stuck in Active Tasks in System monitor. I have tried restarting the services, restarted the computer, and it hasn’t helped any.

The Epicor Task Agent is sticky. Meaning its a pain to shut down or bring back up. Once its up everything but this one report works.

@aidacra Any thoughts on this unusual report issue? We have tried replacing the rdl and redeploying and nothing works.

Update: I ran the report and let it run all night. AT 7:44 this morning it errored out. Then, just a few minutes ago, around 10 am, the report came up.

I think to remove stuck tasks you need to first cancel the task in system monitor, IIRC this creates a record in Ice.SysTaskKill and then you restart the task agent or its services and it should show as canceled.

When you say the report “came up” you mean the PDF appeared?
Usually the report time is divided between data retrieval/dump and rendering of the rdl, maybe everything was collected and dumped but the RDL took too much time rendering and somehow the task errored out before rendering finished.

Yes, the PDF came up. If that is the case, how is it fixed?

The Reporting Services database should have some analysis views where you can see how much time was spent on each step, if the problem is the data retrieval it needs to be fixed by Epicor.

If it is the rendering then maybe the RDL can be tweaked by you to print in a timely manner.

Either way to be fixed by Epicor in the base product it needs to go through Support.