BAQ Query Execution Plan

When I attempt to Get a BAQ Query Execution Plan I receive the following:

Can anyone advise.

BAQ Execution

17/04/2020 - execution circa 3,000ms
20/04/2020 - no execution - same query - no changes - timeout error
20/04/2020 - an And has been added (by the system) to Joins as the first Table Relation on all Joins

I have now changed to

20/04/2020 - manual removal of all the And Table Relations that have been added by the system
20/04/2020 - execution circa 220,000ms
20/04/2020 - execution circa 36,000ms - add Company = BAQ CurrentCompany constant to Table 1

This is very strange behavior - has anyone seen this before?

BAQ Execution

20/04/2020 - execution circa 20,000ms - no changes

BAQ Execution

20/04/2020 - execution circa 72,000ms - no changes

The error in the first message means that you need to click Test button in the query designer first, and then look at the query execution plan.

If it still does not work, use SQL profiler to capture your query and then run it in SSMS to look at execution plan.

Thanks Olga.
I’ve hit Analyze - then Test but still no Query Execution Plan.
I’ll try through the SQL Profiler.

Agreed with @Olga, you need to Test the BAQ once you get the data grid to load then you can export the SQL Execution Plan and open it up in SSMS to see the results.

hit Test, not Analyze

Hi Olga,

I have hit Test - still produces the same error.
Not sure what might be causing this?

i am not sure either… What SQL server version do you use?

We use SQL Server 2018 - v17.9.1