BPM Data Form in 10.2.400.13

I’m probably going to start a support ticket with Epicor too, but this seems like such an obvious issue that I feel like I must just be missing some obvious configuration change needed going from 10.1.500 to 10.2.400. This used to work!

I’ve created a very simple BPM Data form from scratch, and calling that from a simple BPM method directive that simply shows the BPM Data From with a Call BPM Data Form widget and then proceeds conditionally based on whether OK or Cancel was clicked. We also already have in place several BPM Data Form calling directives that worked fine in Epicor 10.1.500.14 but now throw the same exception. The exception is:

Application Error
Exception caught in: Ice.Lib.EpiClientLib

Error Detail 
Message: The process caller failed to invoke method LaunchForm in Ice.Lib.App.Launch in Ice.UI.InfoPromptForm.dll
Inner Exception Message: Exception has been thrown by the target of an invocation.
Program: Ice.Lib.EpiClientLib.dll
Method: InvokeReflectedMethod

Client Stack Trace 
   at Ice.Lib.Framework.PCallReflector.InvokeReflectedMethod(MethodInfo Method, Object Object, Object[] MethodParams, String className, String assemblyName)
   at Ice.Lib.Framework.PCallReflector.LaunchDotNet(String assemblyName, String className, Hashtable ctorList, String methodName, Hashtable methodList)

Inner Exception 
Exception has been thrown by the target of an invocation.

   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Ice.Lib.Framework.PCallReflector.InvokeReflectedMethod(MethodInfo Method, Object Object, Object[] MethodParams, String className, String assemblyName)

Inner Exception 
Object reference not set to an instance of an object.

   at Ice.Lib.App.Launch.AddMenuArguments(LaunchFormOptions lfo, Object launchObject)
   at Ice.Lib.App.Launch.LaunchForm(Object launchObject)

I meant to add and forgot - the main reason I’m posting this here and not simply starting a support ticket is because I wondered if there wasn’t some other way to accomplish this same task - popping up a dialog box with a question and then getting a yes or no response, then having your BPM flow conditional on that response.

Okay, the plot thickens. Turns out I can get a BPM Data Form to work as long as it is attached to a method directive hit while in regular Epicor. It seems the exception is only thrown while in MES. Would this still be a bug though? That is where our BPM Data Forms mostly pop up in our current production 10.1.500 instance, did Epicor remove the availability to use BPM Data Forms from MES?

After figuring out it was an issue with MES and BPM Data Form, I was able to find a Problem in EpicCare support portal for this. I’ll be creating a case to report it is broken in 10.2.400.13 as well.

Problem: PRB0216510

The correction / retrofit to this issue is currently scheduled for the 10.2.400.17 Update.


Thanks Rich… I was just going to say I heard back from Epicor support:

This issue you have reported is scheduled to be fixed in the 10.2.400.17 update. I’ve already requested to see if there was any chance of getting this pushed forward and it is stuck at the 10.2.400.17 release.

10.2.400.14 came out around 10.25. The releases are put out every 2 weeks which would put the 10.2.400.17 release around the first two weeks of December. If this is essential to your Go Live then I would wait until this time to receive this fix.

Just came into this problem testing upgrade to 10.2.400.11 and did track it down to when it’s called by MES. Good to hear that it will be fixed soon.

:frowning: Most recent update from Epicor on this:

The developer says that this is scheduled to be looked at in the beginning of January under our internal ERPS-128639 task that is linked to PRB0216510.
Since updates come out very two weeks and it takes a few updates to make it from looking to release. I expect sometime in February it would be available. I can keep this case open until I get a definite release for you though.

Still broken as of 10.2.500.11. It’s going to prevent us from upgrading… boooooooo

@pferrington looks like you’re looped in on that one. Any outlook for us mere mortals for the fix on this guy?

Anyone that this affects it is targeted for ICE 3.2.700. The latest version you can run without it breaking is 10.2.400.9

10.2.700? Wait, @Rich wrote it was already targeted to be fixed. in 10.2.400.17 that was long time ago. It didnt make the cut?

We are likely discussing different issues.

I believe what Joshua is referring to is a relatively new issue that was submitted to Dev on March 8th. This specific issue is BPM Data Form not able to run from MES with a Customization. Yes that one is indeed targeted to 3.2.700 because 3.2.600 has been locked down for release preparation. That does not mean it is the only version we will fix it for. Epicor’s policy is to fix the issue in the ‘vnext’ version of the product, confirm the fix via QA and only then apply it to earlier releases. This issue is currently pending QA resolution.

I have tentatively targeted updates 3.2.400.27 and 3.2.50016 for retrofits - that is as soon as we can get this one deployed.

Please bear with us this has come in as 3 separate issues:

  1. BPM Data Forms do not work with customization
  2. BPM Data Forms do not work in MES
  3. BPM Data forms do not work in MES with customization

it is unusual but it happens and we have resolved them as they have come in. The 3rd issues, the one Joshua is referring to, did not make it to development until the 8th of March. We excepted it on the 10th of march and put it into our very next sprint. Normally we do not get issues chained together like this.

So for those of you following along:
PRB0213792 - BPM Data Form customization is not applied at runtime.
submitted to development: June 19th, 2019 - resolved by development July 1st, 2019
updates provided into 400 code base (original fix was while 3.2.500 was in development)

PRB0216510 - BPM data form not able to be loaded from the MES form.
submitted to development: October 19th, 2019, Resolved by devleopment November 8th 2019 in 3.2.600
Updates applied to 400 and 500

PRB0221900 - BPM data form not able to be loaded from the MES form, with customization
Submitted to development on March 8th, 2020. In QA testing Queue, likely to be resolved in the next 5-10 days depending on testing priorities.
Updates scheduled for 400.27 and 500.16

This is where all the confusion is coming from 3 interrelated issues that we could have wished we had spotted all at once, but did not, but I promise we are turning them around as quickly as we can. If your specific problem is BPM Data Forms IN MES WITH Customization - the solution is coming. If it is one of the earlier 2 flavors your solution has likely already arrived - check with your support representative as needed.


I didn’t mention it, likely because of how late it is :slight_smile: but this last fix will also be in 3.2.600.2

.16 perfect that’s the answer I have been waiting for. It gives me a timeframe to let my users know when we can upgrade. As soon as that’s fixed we’re a-go. Funny thing is from MES I have a customized BPM Form that fires and it works fine. The ones that don’t work are the BPM forms fired from sub forms of MES. Either way thanks for the update @pferrington

I have hit this issue also with BPM form not loading from MES. All I wanted was a simple YES / NO message. Think I already know the answer to this, but is there another way, maybe using the BusinessObjectMessageType I can’t see a way, but maybe someone cleverer than me can :wink:

I would check with support there might be a patch for you, but if you’re on 300 I’m surprised it hit there too.

I’m on 10.2.400.15 but interestingly, if I add a customisation to the BPM Data form then it worked.
So launching the BPM Data Form from a BPM In MES generated the error mentioned at the beginning of the thread, but if I add a customisation to it the form loads.

weird that’s the opposite of the PRB. Well problem “solved” then ha ha

Interesting… I need to try this!

So add the customization to the BPMDataForm?

The customization was to the MES program itself, the sub-program, or the BPM Data Form itself?