Change Theme Color

Can someone tell me what needs to be edited in the theme to change this color circled in red in 10.2.300.7? This white color is not very visible.

Fix Grid Group by Style Read Only bug

  1. Find the following Section in the Style isl file

<styleSet name=”EpiReadOnly” basedOn=”Default”>
<styles>

  1. Insert the following Style in the above section

<style role=”GridGroupByRow”>
<states>
<state name=”Normal”>
<resources>
<name>EpiGridGroupByReadOnly</name>
</resources>
</state>
<state name=”ReadOnly”>
<resources>
<name>EpiGridGroupByReadOnly</name>
</resources>
</state>
</states>
</style>

  1. Find the Resources Section

<resources>

  1. Insert the following Resource in the above section

<resource name=”EpiGridGroupByReadOnly” backColor=”255, 0, 0″ foreColor=”White” backGradientStyle=”None” backHatchStyle=”None” />

  1. Change the back color to your hearts content
  2. Save the isl
  3. Deploy /Load the Theme

Looks like the Michigan Snow Colors - You Themed it for the Season bright?

Looks like they even messed up the Grouping Section from the usual Light Blue.

What is the default theme file? Is it Epicor-ERP10?

I found the default theme!

1 Like

You guys are the best! This worked great! I also deployed it to all users. :slight_smile:

1 Like

So for anyone reading this after today… You simply found the Default Theme… somehow Epicor had a diff Theme set? or did you modify the .isl file with Jose’s fix? or Did you even just go to an older Epicor Version and exported the theme and just re-used it, honestly .isl doesnt change much :slight_smile:

OK! to help you out here. Good comments Haso!

To find the default them in 10.2.300.7 using the Active Home page I clicked on the down arrow near my name and company listing. I then clicked on Manage Settings. As long as you have access to manage themes you will have a Theme Maintenance option. If you click on this a form will open. Click on Name and then search. The theme that is the loaded default will be checked in the search screen.

I modified the default ISL file which is “Inspired” in our system. I added the suggested records that Jose provided. I updated the color to meet a standard we have.

Finally, to make sure this was deployed to all users I clicked on the Theme Maintenance option and then I clicked on the Action Menu and selected Import Theme Styles. I picked the modified Inspired ISL file on my computer and loaded it. Then, I went to the other users computer. Had them close and reopen Epicor. I then tried the theme change in color and it was showing properly on their screen.

Thanks again for all of the help!

1 Like

I follow you until the last step… after I import the theme style I can see it on my local machine when I restart, but when I go to another user’s computer the theme does not show up. I created a copy of Office2007 (“Office2007-Test”), made the changes locally, and then imported. I feel like I may be missing a step during import which moves the ISL file to the server or something?

Edit: It appears that if I log in on a different the theme shows up, it just doesn’t show up for other users. I imported the style in Theme Maintenance, made it distributable, and made it the default. What am I missing?

@Epicorus - Did you ever figure this out? Thanks!

Edit - I had a theme applied under Settings > General Options > Preferences > Theming tab. Once I deleted the theme name so it was blank, it worked on the next login. Fixed!

image
image

to:
image