Context menu to show up for all users

Does anyone know how to get the context menu items to show up for all users? I set a dashboard to show up on Part.Partnum, then found out that it’s a personal setting. So then I changed to customization mode, and it won’t show up for anyone. I tried an IIS recycle, but still no go. What am I missing? Help files are not helpful.

1 Like

Did you clear client cache when testing?

Just tried that. still no luck.

Maybe I was just being impatient. I put it in both the customization mode, and my personalization mode and now it’s working. Not sure what made it show up, but it is.

I am seeing the same thing here. I made the change with the customization checkbox checked. No one can see the option when they right click open with. The documentation makes it seem like it should just work.

Anyone else know what needs to be done for the context menu item to show up?

1 Like

I’m having the same frustration in 10.1.600.10.
What’s the magic potion to make this work?

I had this messed up.

Since I did it with and with out the checkbox. The personalization for me was grabbing the wrong one.

I deleted everything from my personalization and then it worked.

Ok, I think I have deleted everything started over, still not working.
What the heck am I missing?

Be careful, there are three two modes in context menu definition a personal and customization mode. Just like form personalization and customizations. After deleting, be sure to exist-logout and login again. Before defining your menu context check customization first:


Ok I think I got it, for other poor tortured souls, here was my problem and step by step how to fix it:
Problem: to test I created a personalized context menu, and then I wanted to deploy it i just went in per the Customization User Guide p.572 (10.1.600) and I checked the customization checkbox and setup the new entry. And as previously mentioned this causes conflicts, so I tried to delete my personalization but that wasn’t enough, here is what I did:

  1. Open Context Menu Maint & enable Customization Mode
  2. Recall the Context Menu, note the Current Status (probably not ‘Base’)
  3. Delete the Context Menu via the toolbar (don’t worry you can’t delete base). A warning message will appear, say ok.
  4. Clear the form,
  5. Disable customization Mode
  6. Recall the Context Menu & Note the Current Status (probably not ‘Base’)
  7. Delete the Context Menu via the toolbar. Answer ‘OK’ to the warning message.
    8 Clear the form.
  8. Make sure customization mode is disabled.
  9. Recall the Context Menu
  10. Delete the Context Menu, at this point I rec’d an error message that I could not delete base, so I know I was really at base.

Modify the Context Menu for everyone:

  1. Clear the form
  2. Enable customization mode
  3. Recall the Context Menu
  4. Add the Menu Item and save
  5. Note that the Current Status is now Customization.

For me this is when it worked consistently.

To complicate matters, I was working with the JobHead.JobNum Context menu and apparently there is a rouge version out there that is not the one called up in Context Menu Maintenance. The context menu in Job Entry & Mass Issue is not the same. After completing the above steps the one for Mass Issue was correct, which is all I ever needed anyways.

So glad this is done.


I know this post is old, but I wanted the answer out there to help others. There is more than one JobHead.JobNum (this one fires from Mass Issue as stated). The other that fires from Job Entry/Job Tracker is MFGJobHead.JobNum. This tripped me up for a while also.


Fantastic directions - worked a charm for me - many thanks