Customization Not Available For Selection

I have a customized MES More Info form and when I try to add it to a menu it’s not available, the drop down list is empty. This is on 10.2, oddly it works on 10.1, I can select the customization in the menu no problem.

Troubleshooting steps so far are: Tried to import through solution workbench from 10.1 to 10.2 did not work. Tried saving with and without all companies flag set no joy.

Very strange, has anyone else seen this before?

Any time you customize a sub-form, you must create a customization from the calling form with the EXACT same name - even if it is empty. You will then see a customization from the main form and then that form will pass the current customization to the sub-form.

Thank you Mark I’ve done that before but never tried calling using custom menu (Menu ID) that is pointing to the sub form customization. If I leave the customization drop down empty will the parent form automatically open the customization providing it is called the same?

Yes, I believe that the parent form knows the customization and passes that to any sub-forms. You COULD have multiple sub-form customizations (or none) so Epicor needs to know which one to call. Leaving the parent customization blank will call the non-customized version of the sub-form.