DMT Error

I am trying to update the PO Release. Open the Release and UnVoid a Release. What is this error?

It appears to be GL Control related. You might need to respecify the GL for each

Also, did it fail on just the first 12 records and you stopped it, or on every record?

1 Like

That was it. So how do I link that when pulling it in SQL?

Were those releases anything special (GL wise)? Like shipping to different warehouses or plants that use differnt GL Controls?

not that I am aware of. I have asked the buyer.

While creating a PO does not create any GL trans, it does set things up so the releated PO receipts will.

Open the PO with PO tracker, and check the Release sheet. It will display the GL to be used (or blank if using a default for the context - like Invnetory GL acct for Purchase for Stock)

Not sure I am following you. I know where it is on the PO but it is not a feild on the PO Rel and when I look at the Tech Details on field help…I am not sure how to link the tables and what table to pull the GL number out so I an put it in the DMT. I see the DMT has the field for upload…I just don’t know how to get it out.

Well, I tried added that GL column and still getting an error.

You are correct, the GL acct isn’t saved with the release, but rather an entry is created in the TranGLC table, for future use by the PO Receipt function.

What might be happening is that values exist in the TranGLC table for those PO/Line/Releases. Trying to update them (via DMT) without providing whatever info it wants to set those up, my be creating the conflict.


I’m guessing that you need to supply the PORelTGLC.TGLCTranNum num as well.

Make a BAQ with tables PORel, and PORelTGLC. Probably need to add a table criteria on PORelTGLC limit it to just the PORelease related entries.



Table TranGLC, not PORelTGLC

The TranNum is almost always 1. But I did find some entries where it was not


@Kimberley - Really dumb question … Are you sure it is in plant MfgSys, and not mfgsys?

And why even provide the PlantID?

Also, that error looks like it cannot find the record in question, based on the Company, PONum, POLine, PORelNum, and SysRowID.

Make a BAQ for the PORel table showing fields: Company, PONum, POLine, PORelNum,Open, Void, and SysRowID, for PORel.PUNum = 209403


Then run your DMT with tracing enabled (full data), and see if the PORel section has that SysRevID


Does the trace show that record?

I will try it. I took plant out since it wasn’t required.

The Data Dictionary for PORel says:

Indicates if the release was voided. Voided releases items are not main tainable, can’t “unvoid”. This field is not directly maintainable. Instead the void function will be performed via a “Void Release” button. Which then presents a verification dialog box.

When an PORel record is ‘voided’, PORel.OpenRelease is set to “no”.

A test shows that a Release’s state is a combo of the OpenRelease and VoidRelease fields.

Open  Void   State
  1      0    Open (available to be received)
  0      1    Voided (By using 'Close Release' on the action menu in PO Entry)
  0      0    Closed (received)
  1      1    NOT ALLOWED

So try just setting the OpenRelease to true, and ignore VoidedRelease

I saw that too and wondered if it was even possible in DMT.

I have just tried opening the release but I still get the same errors.

It’s just that one PO, correct? Can you just re-open each line and release via PO Entry?

I know it doesn’t solve the problem of doing it with DMT. But does get the PO fixed.

While not knowing why something was broken drives me crazy, you have to just move on at some point.
Re-visit it if it shows up again.

It was just one but now I have a second one. We can but there are over 200 lines and some release go into the 90’s…just a lot.

They are opening as they need them i am just trying to figure out what is going on with DMT and not why are POs randomly setting Releases to Void. The second on yesterday happened when they were at lunch. I had the user change their password but I don’t get it.

I’d enable the change log on PORel ASAP!


Also, does the line then close too? If it doesn’t, then something is bypassing the business logic.

No the line did not close…Just a bunch of Release got voided. I have the change log on and can see who did it but how could they Void 50 to 60 maybe even more Releases on various Lines all with the same time stamp.

I have a copy of the DB in another environment but I don’t even know where to start…crazy.

Does it always void every release for that line?

Does the Change Log for POLine show any activity at the same time the PORel.VoidRelease changes? Particularly if the POLine.OpenLine changed to false, and then right back to true.

I was going task if a Hotkey was assigned to the Close PO Line action, but even that generates dialog box


In PO tracker are these releases attached to a Job or Sales Order and are people meddling with that Job or Sales Order?

Are there any PO change suggestions against any of these releases? Even if they don’t show up in the change workbench they will still be listed in the database as reviewed

Also if a PO line or release is closed and there were no receipts against the line, the release will be voided. So a user could theoretically go into Change PO Suggestions, check all of the boxes for cancel orders and use the Action pull-down to indicate ‘Accept’ to cancel(void) a ton of releases at once.