DMT Inventory Transfer

Hey All,

I’m getting this error when transferring from one bin to another in the same plant… Any ideas?

Object reference not set to an instance of an object.

It’s coming from TGLPS Plant with from PARTS to FRAN which has the which is one the same plant but different bins…

Any ideas? Error doesn’t tell me much.

Do you have any BPMS or data directives turned on?

Not that I know of… Let me check.

No BPMs or DDs in the way.

Think it might be verison issues.

Here is a more in-depth error

System.NullReferenceException: Object reference not set to an instance of an object.
   at Erp.Services.BO.InvTransferSvc.ChangeToBin(String ipToBinNum, InvTransferTableset& ds) in C:\_Releases\ERP\UD10.2.400.38\Source\Server\Services\BO\InvTransfer\InvTransfer.cs:line 596
   at Erp.Services.BO.InvTransferSvcFacade.ChangeToBin(String ipToBinNum, InvTransferTableset& ds) in C:\_Releases\ERP\UD10.2.400.38\Source\Server\Services\BO\InvTransfer\InvTransferSvcFacade.cs:line 211
   at SyncInvokeChangeToBin(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   at Epicor.Hosting.OperationBoundInvoker.InnerInvoke(Object instance, Func`2 func) in C:\_Releases\ICE\ICE3.2.400.38\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 59
   at Epicor.Hosting.OperationBoundInvoker.Invoke(Object instance, Func`2 func) in C:\_Releases\ICE\ICE3.2.400.38\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 28

I’ve had issues in DMT when I didn’t have my columns in a specific order.

Try putting PartNum second after Company

No luck with that.

Can you do one of those transactions manually without error?

Hi Ernie,

No issues at all… I have now tried a different version of DMT and still same issue.

I had some issues with the DMT if the last Plant used by the account running DMT was not the same as the Plant in the file. Logged into Epicor moved to correct Plant did a screen transaction (did not need to be an update) and then logged out prior to starting DMT.
This did not solve all the problems and in the end used Paste Insert on the screen to clear the problem transactions.

I’ve had all kinds of fun getting this to work in the past. Have you tried it without setting a TranDate? the other thing from Experience is Case sensitivity, I had my plant field in all capitals on my CSV BUT on Epicor it was proper case and that was throwing an error (although I cant recall the error at this time)

It may not be ideal but maybe do two dmt for qty adjustments.

Did you try a trace?

image